C++ work fine play in edit but crash at launch

I defined some structures in c++ files. And it work fine when I play in edit but crash at launch or run a packaged game. The log shows

[2017.06.05-03.19.43:251][ 0]LogProperty:Error: Struct type unknown for property ‘StructProperty /Game/ResetAllKeyBindings.ResetAllKeyBindings_C:SetAllKeyBindings.CallFunc_GetDataTableRowFromName_OutRow’; perhaps the USTRUCT() was renamed or deleted?
[2017.06.05-03.19.43:254][ 0]LogMac:Error: appError called: Assertion failed: Assertion failed: Object [File:/Users/build/Build/++UE4+Release-4.16+Compile/Sync/Engine/Source/Runtime/CoreUObject/Private/UObject/LinkerLoad.cpp] [Line: 3049]

I don’t know how to fix it. plz help me.Log file

I analyze the log file and found there are some bugs in blueprint’s cast function.Log file can help you to locate the bugs

Sorry to reply late. after that I went to bed.

Well. If you don’t mind, it would be a nice idea.

So, would you send your project to me?

Sorry I can’t locating the server list bug. I tested on a PC and a Mac. On Mac, udp port 7777 was listened by game correctly. On PC, I cannot listen the port. And both of the pc and Mac cannot send the message through udp. It seems like a plugin’s bug. Have you fix it?

Have you find the solution? I Have the same crash :frowning:

Yes! I solved the problem. Do you have log file? I need log file to solve the problem.

so how you solved this problem? help plz.

Can you tell me more in detail please? Where can i get this log file and how to analyze it?

Well. My English isn’t good and I don’t know if I am clear.

In unreal editor, package a game for your platform.
open output window and wait it. when package finish, the output window should printed a lot of logs.
then scroll the output window from button to top. if you see some memory message, everything works fine. otherwise, find which file built last, that is the file with bug.
if the log of package show up some memory message, then run the game. if the game crash, there will be a crash reporter window show up. In the second container of crash reporter window, the first line, there are some words clickable, that will show you the log location. In the log file, you could see which file doesn’t work fine.

My english isn’t good too, so there is no any problems.
Look. This is my error message when i try to launch compiled project.
Then you can see my compile log text. Also i found crash logs in game directory. I see several errors in the end of the file, but i dont understand how to fix it, can you help me with this?

202775-снимок.png

[My compile log][2]
[Crash on launch log][3]

OK. I will help you.

Maybe we come from the same country. And we can communicate in the same language. Where are you from? Russian?

Yep, Mother Russia.

Could you please take a screen shot of your project package setting?
And would you mind package one more time and give me the log? I need more than one log file to check which bug cause this problem.

There may be some problem with your user widget file widget_ServerEntry. Is there a function called GetExtraSettings? and the function has an output named “ExtraSettings” which is a structure defined by yourself. Please try to delete it or change it to some const value and package again to see if the problem is still there.

Unfortunately, I’m Chinese. And I can not speak Russian. Too sad…

i delete widget file widget_ServerEntry and cut every connection to it. still got same lauch error. here u can see setting screenshot + new package log and crash log.

[crash log][2][compile log][3]

please show the config under packaging’s advance category. the expand arrow in packaging category. Expand all packaging selections please.

this?

Please check if the file named “ThirdPersonGameMode” in your .pak? If not, please check if this file have been cooked or not.

If I understood you correctly… i unpacked file .pak in …project_name\content\paks and yes ThirdPersonGameMode is in this .pak file.