C++ Third Person Template's networked multiplayer does not work

There is an issue with possessing the first created pawn when attempting to play 2+ players in the C++ third person template whether you select Dedicated Server or not. This issue arises on versions 4.11 and 4.12. The Blueprint version of the Third Person Template works just fine.

The player cannot move and the pawn remains suspended in the air, which leads me to believe this is a problem with the Character Movement Component. Another reason is that possessing non-Character Movement Component pawns seem to work fine, like for example a Vehicle or Spectator pawn.

Hey eZinc-

Are you setting Number of players in the Play drop down to 2 or are you creating a new player with the Create Player node (single screen network multiplayer vs split-screen multiplayer)? Can you provide the setup steps you’re using that causes this issue?

Setting number of players in the Play drop down to 2. From there on, the player in the editor cannot move.

I assume it is an error with possessing the Character Movement Component because the character remains in the air – and because there are no issues when possessing say a Vehicle pawn.

This occurs even on a fresh install of 4.11/4.12 on multiple computers.

Hey e Zinc-

I’ve entered a bug report, UE-31170 , to investigate the behavior of the server character not accepting input.

Cheers

Doug Wilson

Hey, just wanted to update this bug report. It’s definitely a problem only related to C++ third person template projects for some reason. It works fine on blank/firstperson templates.

OH WOW! I just realized that the problem stems from “Auto Player Possess” is automatically set to 0 in the newer 4.11/4.12 updates in the default character blueprint. This was the problem the entire time! It should have been set to Disabled. I never realized that until now. Such a rookie mistake of me. I’ve just been using the default character blueprint because I’ve been too lazy to make a new one…

As eZinc stated, go to the “ThirdPersonCharacter” BP, search for “Auto Possess Player”. Set it to “Disabled”. It should work now.