C++ component not shown in blueprint editor??

UCLASS(Blueprintable, BlueprintType, ClassGroup = (Custom), meta = (BlueprintSpawnableComponent))
class DLCOREUTIL_API USplineEx : public USplineMeshComponent
{
GENERATED_BODY()
}

Have a class like this. It just doesn’t show up in the blueprint editor.

Instead, if I subclass USceneComponent, it shows up fine.
It won’t work if I subclass USplineMeshComponent or UStaticMeshComponent etc.

Can someone explain?

285216-bpbug.jpg

Only thing I can think of is you have some sort of caching issue. Try to clean rebuild the project, if that doesn’t work delete your intermediates folder and regenerate project files.

UCLASS(Blueprintable, BlueprintType, ClassGroup = (Custom), meta = (BlueprintSpawnableComponent))
class MYPROJECT_API UMySplineMeshComponent : public USplineMeshComponent
{
	GENERATED_BODY()
	
};

is what I used in a blank project on 4.22 and had it show up in my custom components list.

tried every caching related solution, still no good

Solution Found. sort of…

If I add the BeginPlay to this class, it shows up correctly

virtual void BeginPlay() override;

However, consider what @MJBrune said, he actually got it showing without the BeginPlay().

So I’d really like to know: is this a feature or bug?