Buliding lighting causing lightmass to crash

Hi everyone, I seem to be having a problem when rebuilding my lighting. A few hours ago my PC Blue screened and when I rebooted it and opened up ue4, my level was looking dark, so instinctively I just thought my level just needs building. but every time I try to build I get the same error message under lighting results.

=== Lightmass crashed: ===
Fatal error: [File:D:\Build++UE4+Release-4.19+Compile\Sync\Engine\Source\Runtime\Core\Private\GenericPlatform\GenericPlatformMemory.cpp] [Line: 183]
Ran out of memory allocating 111163859352 bytes with alignment 0

0x00000000AFF9A388 KERNELBASE.dll!UnknownFunction []
0x00000000A84A5E24 UnrealLightmass-ApplicationCore.dll!UnknownFunction []
0x00000000492AA48B UnrealLightmass-Core.dll!UnknownFunction []
0x00000000491ED258 UnrealLightmass-Core.dll!UnknownFunction []
0x00000000490D5925 UnrealLightmass-Core.dll!UnknownFunction []
0x0000000049141E02 UnrealLightmass-Core.dll!UnknownFunction []
0x000000004CFE88EC UnrealLightmass.exe!UnknownFunction []
0x000000004CFBE22E UnrealLightmass.exe!UnknownFunction []
0x000000004CFCFBF8 UnrealLightmass.exe!UnknownFunction []
0x000000004CFF874A UnrealLightmass.exe!UnknownFunction []
0x000000004D036138 UnrealLightmass.exe!UnknownFunction []
0x000000004CF97F8A UnrealLightmass.exe!UnknownFunction []
0x000000004CFCD478 UnrealLightmass.exe!UnknownFunction []
0x000000004CFCFF7D UnrealLightmass.exe!UnknownFunction []
0x000000004CFADD31 UnrealLightmass.exe!UnknownFunction []
0x000000004CFD6D23 UnrealLightmass.exe!UnknownFunction []
0x000000004CFF5D4A UnrealLightmass.exe!UnknownFunction []
0x000000004D071F35 UnrealLightmass.exe!UnknownFunction []
0x00000000B05F3034 KERNEL32.DLL!UnknownFunction []
0x00000000B31B3691 ntdll.dll!UnknownFunction []
0x00000000B31B3691 ntdll.dll!UnknownFunction []

Its definitely got something to do with memory as it says, but I’m not sure how to go about fixing this.
I haven’t had this problem before when baking the lights, worked fine yesterday for example but today not so much. Any help would be greatly appreciated


EDIT: Just wanted to add that I tried increasing my virtual memory and didn’t seem to take effect.

Nevermind. Turns out it was because of one of my assets that had. Must have been corrupt for it to do this. My best suggestion for people experiencing the same. Migrate all you things to a new level and dissect it from there. Or if things are fine before and not working now. Reimport the last few things you’d recently brought in. Hope that helps

thank U !!!