Built Lighting Dark in some places?

When my lighting is built some of the walls are darker than others.
Here are some pictures.

I have tried setting every asset to 1024 lightmap resolution didn’t work
I have use two sided lighting ticked on every asset as well
And nothing I have done has worked.
Please help me.

Could you show your lightmass settings? Do you use CPU or GPU? If CPU, did you change your Lighting Quality Level?


1 Like

I am using CPU and I am using medium lighting quality.

And your Lightmass Settings? (you can find them under World Settings)

Back then I used to have Static Lighting Level Scale on 0,1 and the Indirect Lighting Quality on 10. (Rule of thumb somehow was: if you multiply both you want to get 1,0 as result). Indirect bounces ~ 10. (and disable Compress Lightmaps because of possible artifacts).

Do you have a Lightmass Importance Volume? You could even try to add some Lightmass Portals, covering your windows.

1 Like

I have changed the indirect bounces to 10 and added a lightmass importance volume and added lightmass portals to the windows and unchecked compress lightmaps. Just wating for it to build now.

Ok. Meanwhile: I used these settings most of the time.


Took me some time now, but I finally found my go-to source again:

So, for a quick read:
Tom Looman wrote a summary about a really nice and official video by Epic about Lighting.

Unreal Engine 4 Lighting Masterclass - Tom Looman

And if you have some time to spare:

Lighting with Unreal Engine Masterclass | Unreal Dev Day Montreal 2017

It is fixed when i build it, it is no longer dark in places but walls have artifacts. Is it the Indirect Lighting Quality?

Could be - try to follow the rule with: Both values (Static Lighting Level Scale and Indirect Lighting Quality) multiplied should give you a value of 1. As in my example, the 0,1 and 10.

Even the Lightmass Compress enabled could result in some JPEG-ish artifacts.
The guide above may help you there :slight_smile:

Ok ill set Indirect Lighting quality to 10 instead of 2.
But thanks for helping me to solve this.