Download

Building Lights errors on simple environment

Well this is confusing.

CfVkxDA.jpg

Before building, you can see my corridoor is lit as it should with a static point light. Yet after building it’s blacked out. YET, in the error list the corridor is not even mentioned while bedroom is :stuck_out_tongue:

I looked into the error of “Static Mesh Actor has NULL StaticMesh property” on the official site and it says;

I think they mean the property where you select the static mesh in the component right?

vc68JRs.png

I’m doing exactly the same as the other environment pieces and they get no errors. I’ve created a perfectly simple lightmap in UV1 (not UV0) yet it’s complaining about that also. All I’m doing here is exporting a FBX into my environment folder and then right clicking and creating a blue print from it.

Please does anyone have any ideas on how to possibly fix any of these errors?

Is your second screenshot (the one with the Static mesh property) really from the Actor named “Bedroom_Shell_3”? I think you just have a second actor in your scene that does not have a static mesh set, thus being invisible and causing this warning. And the actor from the screenshot with the static mesh set, is another one different from “Bedroom_Shell_3”, isn’t it?

Yeah it seemed to be using 2 different versions, have now made just one version and it no longer appears in the error log so thanks. Initial issue of the coriddor not lighting properly remains, why would that be resulting in black walls?

Make sure your static mesh has the correct UV channel set to be used for lightmaps, it’s the Lightmap Coordinate Index in the static mesh editor.

As for the other issue, that means there’s a Static Mesh object in the scene that doesn’t have a mesh from the content browser applied to it, so it doesn’t have anything to render.

They were set to 0 so I changed them to 1, saved them but am still getting the same results. They 100% have a LM on UV 1, have checked in the editor and it’s clearly there :frowning:

From screenshot I am assuming that you have a single sided wall if yes! Then try to give your wall mesh some kind of thickness and try also to space out UVs.

Uvs are fine. Material is double sided (added a new material and made sure) Surely the mesh not being double sided isn’t an issue, have never created double sided walls before. Unless this in a new rule for Unreal4?

edit : I mean look at this, I add a direction light and the floor is illuminated but not the walls? Yet they all use the same material.

CFDzOWU.png

  • To get best results out of static lighting, you should have some kind of thickness in your wall mesh. Never work with planes unless you don’t have any second option.

  • Also check if you have lightmass importance volume in your scene for static lighting

  • Check this post out for more information regarding some common issues for static lighting bakes (https://forums.unrealengine.com/showthread.php?46269-Modular-Asset-Lighting-Problem)

  1. I’ve never come across an engine that needs you to build double sided polys even if they are not to be seen by the player. Regardless, I’ve gone and done that to the coridoor piece. Here is the light map;

ExvNINw.png

  1. Added a lightmass importance volume

  2. The example you provided has some good information though it’s more about a weak looking lightmap. My problem isn’t a weak looking light map with seams etc, it’s just not working. I’m guessing it has nothing to do with lightmaps even. Anyway, I put up indirect lighting quality to 4 and smoothness to 0.6. Didn’t work.

One step at a time. Why is this happening in the viewport? I believe this is the key to the problem here as I’ve not experienced it before. This isn’t normal is it? Why does my wall only pick up light after moving the source?

VjC4iU1.png

There is a problem in UE4 when you first import the mesh while it doesnt have second UV channel, and after you fixed it and added second UV and reimported it still has problems.
The solution is rename old mesh or import new mesh with different name.(not reimport) and click objects in map and change mesh pointers to newly imported mesh and delete the old one.

It may be a complication with auto generating second UV’s during import. There is a tickbox for it in import dialog box that you may want to disable if you want to use your custom second UV channel.

Hi,

When you import a mesh with only one UV channel (for the texture), UE uses that also as lightmap index.
When you add a second UV set for the lightmap and reimport the mesh, the mesh is reimported with both channels, but the property in the detauils panel still points to your old lightmap channel.
So no need to delete and reimport, just change that value from 0 to 1…

Cheers,
Klaus

Camer, yep, think that’s my only remaining option now. Will try it.

Jacky, I can’t see a tickbox in the import dialog (when importing a static mesh) for lightmaps?

Kvogler, it’s not this. I’ve made sure that my static meshes ligthmaps are set to 1 instead of 0 and the problem persists.

Generate Lightmap UVs is the name of the tick box. Click the white arrow to extend Mesh tab if you cant see it. This is integrated with 4.5, btw, in case you have an earlier version of the engine.

I have the latest version and yet I have no such options :frowning:

fa537596a1193211bfa1783f12a70af0a893a1b7.png

Well try this and see if it works! Under world settings–>lightmass–> try to give some environment color and make environment intensity to 1. Hope this works. Quiet bizzare issues this is. Hope this works out for you.

It was already set to 1 and I had already changed the colour.

I made some progress. It was more to do with me using shiny material for my surfaces that was causing confusion. Applied standard matt surfaces now and it’s working at least. So now it’s a case of improving them, I’ll go over that thread again where someone had similar issues.

jg3gc1G.png

Argh it’s gone wonky. I’ve been reading that thread again, I noticed that it was said to connect all the UV islands but the chap didn’t do that and it still worked out fine. I think my spacing/padding is good.

It’s either

A) World/LM settings? (Other thread recommended LM resolution 64)
B) That I have no ceiling?
C) I have no skybox and so the environment is just bouncing black around?

a0e772b8496c089ef13523e7c27ed1c82b6b524d.jpeg

Clearly something daft happening here as I’ve deleted EVERY point light, skylight etc (EVERY light!) and yet after a bake some walls and a prop are still lit.

Qp8R2oq.png

Try this: go to world settings and enable Force No Precomputed Lighting. Then build the lights, which should get rid of the lightmaps. And then disable it again and build the lights.