Building Lighting problem

I’m new to UE 4 and I get this grid pattern across a landscape terrain. I understand that rebuilding the lighting will fix this but when I try to build the lighting it never finishes. I had it run overnight and it was still at zero percent the next morning. I created an FPS project from the template and tried building the lighting there but same thing, it just stays at zero percent forever.

What am I doing wrong here? Some incorrect setting or something missing?

-add a lightmass importance volume
-change the light build quality to middle or just to test it, set it on preview
-post your pc specs
-what lightmap resolution do you use on your landscape?
-click on the little swarm icon in the systray and see if something moves :slight_smile:

A lightmass volume is there. I updated to UE 4.8 and now The light building is progressing so I dunno… The grid is still there with Preview setting though.

Where do I find the landscape lightmap resolution setting? There is a texture size setting on the cubes in the scene but I don’t see one for the landscape.
This is on a by now pretty old Mac Pro. 2.66 GHz Quad-Core Intel Xeon with Radeon HD 4870.

-The landscape lightmap resolution can be found in the details panel of your ladscape -> dont go over the resolution of 4-5 (static lighting resolution)
-due to your pc specs it could take a while till the light gets built, because it’s a ressource heavy thing
-I saw a thread about the landscape line problem some weeks ago, I will see if I can find it :slight_smile:

Ah, so the 1.0 value in the settings is the light map resolution? I was expecting a typical texture resolution value like 512 or something. So for better detail I could increase the value above 1.0 then if I understand your reply correctly?

I don’t know if it was the 4.8 update that did it but I can build the lighting now and with a quality setting of High the grid pattern is gone and everything looks fine.

Yep, a higher value means a better lightmap resolution :slight_smile: