Building Lighting Failed and stuck on 0%. What to do?

Hi I am new to UE and the first problem I ran into right at the beginning of the installation is that it shows me an error that I have to rebuild the lighting of an object, but if I hit build or hit build lighting only it builds everything nicely then it stops at the lighting part and after a minute or so it throws an error. I dont know what I might have been missing I didn’t do a single project yet I just moved some cube around and cant get the lighting to get build, it is really annoying, I have experience in unity and Blender and would love to start working in UE as well. I am working on a Mac I reinstalled the epic games installer and the editor and even tried with another version (4.20), same problem.

How are your system specs?
NOTE: unreal does light building on the CPU, so more cores more power here.

I’ve seen this before, and I would just let it run,
but performance is key to building lighting.
This could be a problem with SWARM NOT RUNNING AT ALL, or being restricted to some capacity. LEAR MORE HERE
You can also lower the light map resolution to build faster, LEAR MORE HERE

Thank you for your reply :slight_smile: but I don’t think the performance would be the problem I’ve got an iMac quad core i7 cpu and 16GB ram, but you might be right in that the SWARM does not start at all. I tried clearing the cache as suggested in other forums, but unfortunately it did not help. It is strange because it does not build even the blank scene in a new project :confused: I’ll note that if I add any geometry into the scene the selection light (which indicates that the object is selected) is annoyingly blinking/flickering

I do know in windows it has to have permissions from the system to run, because it uses a local network connection to start and stop (yeah you can do LAN with just your desktop). I would look at OSX 's way of handling network based utilities.

a thing on permissions.

Thank you very much for your effort, everything works! :smiley: All I had to do is repair my disk’s permissions through disc utility (running first aid) then restart the software.
That blinking problem I mentioned was still happening but after a restart it disappeared as well :smiley:
Thanks again

Well if it worked, and the answer is good don’t forget to up-vote my resonances and say the question has been answered., Please and Thank You.