Building Geometry in 5.1 Causes Blueprint items to disappear.

Whenever I open the VR Demo and build the geometry, all of the blueprints in the scene disappear. This includes the Sky Sphere, Grab Actors and Pistols. Anyone else experiencing this issue? Any Idea why this happens?

Yes I’m having the same issue with a number of marketplace blueprints too - It only started happening with 5.1 so hopefully will be fixed in a patch…

Having this same issue, I have saved the scene after build and re-opened it and everything seems to come back.

It’s impossible to build lighting because the blueprints with lights in them disappear when you build lighting, thus rendering the light build useless after they reappear.

I finally solved the problem with the disappearing BluePrints: You need to convert the map to World Partition. So first turn it on in your Project Settings, then CONVERT your level (Go to menu TOOLS, then World Partition, Convert Level), once you do that, SAVE, then go to the World Partition Editor, select the whole thing, then click “Load Region from Selection” and NOW it works.

That works because it disables static lighting… It checks the tag bForcePrecomputedLighting in your word partition setting