Bugs related to VR and loading Data Tables

Since 4.11 was released we have run into a number of bugs that were not present in 4.10 and have affected our productivity significantly.

First off, when running in editor in a VR preview, we used to be able to alt+tab back into the engine then back into the preview window in order to watch the log in real time behind as we tested. In 4.11 however, alt+tabbing even temporarily or otherwise losing focus causes the frame rate to permanently drop and input no longer works. The motion controllers will move, but the buttons and triggers no longer give input, nor does the keyboard. We’ve been able to work around this somewhat by testing in short patches and using our memories, but it is extremely limiting. Is a fix for this in the works? As stated, it worked fine in 4.10.

Secondly, a number of our assets and variables are loaded in from data tables, which worked fine in 4.10 as well, but does not work consistently at all in 4.11. Upon freshly compiling the project, we will either have it working on the first play, or the second. As of 4.11.2 it always works the first time, however it stops working and needs to be rebuilt if we quit the preview. Recently it also fails even during the running of the project, which never used to be a problem. Obviously, recompiling every time we want to hit play is a pain, especially when making tiny cosmetic changes. It worked fine in fully built projects consistently in 4.11.1, but we have yet to build an executable in 4.11.2. Either way, the bug is in the editor.

Hopefully both of these issues have been noticed and a fix is in the works for 4.12. Both features worked fine before, so I’m not sure what broke them. Hopefully it is a minor issue. Thanks.

Hello ,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce these issues in a clean project?
  2. If so, could you provide detailed sets of steps to reproduce these issues on our end?
  3. Could you provide screen shots of any blueprints that may be involved with these issues?
  4. What VR device are you using?

Hello ,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.

Hey Rudy,

Sorry for not getting back to you sooner, we were at a conference which unfortunately consumed most of our time. In regards to the first issue reported, it turns out the problem was on our end, and we have since been able to resolve it. As for the device we are using, we primarily use the HTC Pre for our in editor testing.

Regarding our second issue, we were unable to easily replicate the problem in a clean project. However, during our attempts to do so we managed to isolate the source of the problem. We are passing a fair amount of data through a BlueprintImplementableEvent so that we can edit UMG Widgets at runtime. The blueprint that handles this works just fine, however it seems to also be the source of the problem. On the first run, it works fine, but upon pressing play again, editing any values in editor, or even transitioning between levels, it fails. It may be a garbage collection or memory issue, but at some point the editor stops referencing it properly or something. We have found that simply opening the blueprint and hitting the compile button causes it to work flawlessly every time until we either close the engine or perform a hot compile. I’m including a screenshot of the blueprint in question for clarity, but I am not sure why it fails in this way. Perhaps you guys can gain some insight from this that we can’t. At least we’ve found a workaround, and it works fine in a packaged game.

Hello ,

Would it be possible for you to provide a simplified version of the project that is currently showing this issue? Could you also try using File > Refresh all nodes on your blueprint that you need to keep recompiling?