Bug with raytrace shadows/dynamic lighting and Nanite + VirtualheightfieldMesh


I have two issues that seems related with Unreal 5 Preview 1.

On the left there is a dark spot that just shouldn’t be there. When I move the camera it evolves. It’s generated on a VirtualheightfieldMesh.
On the right there is 2 versions of the same mesh, the right one is the nanite version where the shadows are off.

Both issues disapear if I disable ray traced shadow or dynamic shadow on the light. I have tested a directional and a spot light and got the same issue.

In the World Settings I have enable “Force No Precomputed Lighting”

Switching the project & post process to lumen doesn’t remove the issue & Virtual Shadow Maps are enabled

Please can anybody help ?

Not terribly sure about the shadow issue on the left, but the black splotches on the nanite mesh on the right could be caused by the proxy mesh, as RT uses the proxy mesh for shadow casting.

I found this slider changes the accuracy of the proxy mesh, i tried a few options but setting it to 0 removed the issue completely. I’m certain this has some performance impacts.

before and after:

Hi, yes you are right @insideitall it is caused by the proxy mesh.

I did find a way to solve this by disabling doublesided geometry with a console command and William Faucher made a video about it where almost all solutions are presented here: Fixing the Ugly Shadow Issues in Unreal Engine 5 - YouTube