[Bug] SceneTexture adds jitter effect

In 4.17.2, when using a scene texture node for a post process effect most of the SceneTexture ID’s appear to add a screen-shaking effect, as if the post process effect for ‘grain jitter’ was turned on. This issue can cause problems with some post process materials like ceil shading, seen as the fuzzy shadows here https://i.imgur.com/vgWyVYd.png

Notice the screen shakes very slightly in the example using SceneTexture:WorldNormal Imgur

Note- the fuzzy effect of the shadows in the first picture are effected by a post process volume’s ‘Grain intensity’ parameter even though both it and Grain Jitter attribute is unchecked (and Grain Jitter is set to 0)

Steps to reproduce

  • Create a post process effect with a
    single SceneTexture node attached to
    the output’s Emissive parameter

  • Note that the node can use a Texture ID of World Normal, Metallic, Diffuse, BaseColor, Ambient Occlusion, or nearly any other ID except for PostProcessInput0. (example here https://i.imgur.com/3VyIpCw.png)

  • Create a post process in any level set to unbound and Post process materials to have the one just created.

  • Notice that the screen shakes slightly when the post process uses one of these SceneTexture ID’s.

Desired result: SceneTexture should not jitter/shake when used.

Hi m500,

For your Material, do you have the Post Process Material > Blendable Location set to “After Tonemapping” or “Replacing Tonemapper”? What happens if you change the settings?

Hello Jon X :diamonds::diamonds:,

The Bendable Location was set to “After Tonemapping”. Changing it to Before Tonemapping does resolve the issue and the SceneTexture ID’s do work as intended. The issue may be due to PostProcessInput0 using HDR while in all of the other SceneTexture ID’s use LDR for colors in '‘After Tonemapping’ and dividing them together yields artifacts due to one node using colors from a high to the other in a low range.

Hi m500,

I’m glad changing the Blendable Location setting to Before Tonemapping resolved the jittering issue. I’m going to go ahead and close this issue as resolved, but if you require further assistance, feel free to reopen the thread with a comment and we can investigate further.