[Bug] Lighting issue in 4.5.1

I just upgraded to 4.5.1 from 4.4.3 and I’m seeing some unusual lighting behaviour. Random foliage (all foliage is the same mesh) on my landscape have turned black. Rebuilding the lighting doesn’t fix it.

Any idea what’s up?

Hey Antidamage,

Are any of these static meshes instead of foliage meshes? If the one that are black static meshes, try updating the lightmap resolution of the mesh itself. If this does not fix the issue let me know!

Thanks

Andrew Hurley

As noted, none of them are static meshes and the lighting rebuild has already been attempted.

I might try removing them and readding them, could just be a conversion bug between 4.4 and 4.5.

Interesting, do you know if you used the convert-in-place or open a copy option when moving from 4.4 to 4.5? The convert-in-place option seems to give users some issues when porting to the newer versions. Let me know if you fixed the issue as well.

I used convert-in-place. I have a backup of it though that I can try when I get home tonight.

I’m noticing that as I remove and re-add trees, some of them still turn black. Then about 30 trees I placed that looked fine all turned black at once, then came right again. Unless it’s a conversion issue with the landscape they’ve been placed on, it would seem to be a bug with the way foliage renders its lighting.

Excellent, I’ll check it out. Thanks!

The convert-in-place option currently is known to have issues with lighting and other meshes being damaged or corrupt. This sounds like it is the case, so with the copy of your project you have, when moving to 4.5, use the open a copy instead and see if this fixes your problem.

Also within Foliage Mode there is an option that says show instance settings. Within these settings there is also a Lighting section. Here you can set the shadows and a few lighting options for those particular meshes in game.

You are welcome!

I quickly remoted in and tried doing a copy-and-convert with the backup. The black trees still exist. Would it help if I sent a copy of my project through? I believe the marketplace review team has a copy of it and I’ve been meaning to update it with the 4.5 version.

If you don’t mind sending a copy then that would be helpful! I could more easily help you solve your problem.

Not a problem. What’s your email address? I’ll invite you to the shared folder.

We only allow users to provide us with projects via DropBox or private messages me on the forums. My name there is AndrewHurley. Thanks again!

Thanks! Message sent.

Hey Antidamage,

I have tried reproducing your issue as far as the instance settings crash to no avail. Would you mind sending your call stack and crash log so I can further investigate.

On a side note I really like your cel-shading design and your level layout! :slight_smile:

Hehe thanks. :slight_smile:

I’m not sure which log is relevant, so here’s the lot: Logs.zip

Perhaps I’m just getting general instability. Last night my issue was crashing whenever I tried to place or interact with a BSP object. After a few crashes it settled down and I was able to work with a BSP object for long enough to get what I needed to do done.

Awesome, I will take a look at these logs and see what is happening. Also BSP’s are sometimes known to cause your projects to crash as well. I will do my best to see how we can resolve your issues!

Hello again Anti-damage,

I have been trying to get your project to crash by pulling in some new BSP’s but with no luck at all. As you mentioned this could be just general instability pertaining to your specific machine.

As of recent, have you been able to make edits to your project without these issues constantly occuring?

That’s right, I guess it’s a non-issue now. Sorry for the bother.

Not a bother at all! We like to make sure the issues either have a temporary work around until fixed, or it has been resolved!. Keep up the cool work!