Bug: Instanced Foliage Not Affecting Navmesh

Heya,

Here is the problem:

On the right is the same tree but placed directly as a static mesh in the scene. On the left is the foliage painted one. It has collision enabled and the navmesh becomes dirty when I place it, but it recalculates covering the tree area as if there’s no collision. This current setup is using a NavigationInvoker agent, but the result is the same with traditional navmesh.

Just to note - making my static meshes Dynamic Obstacles and restarting the editor makes them generate the navmesh slices. But since my trees won’t be walking around anytime soon, I’d like a solution that is not a workaround.

Hi DamirH -

Thank you for your report. We have assigned this issue to a member of our support staff, and they will begin investigation as soon as possible. If we are unable to reproduce the issue, or we need additional information, our staff member will comment here with additional questions. Otherwise, we will post an ‘Answer’ once we have logged the issue in our bug database or we have a solution for it.

In the meantime, please be sure to review our suggestions for how to report a bug, and feel free to edit your post if you have additional information to provide:

Thank you -

Eric Ketchum

Hello DamirH,

There is a setting within ‘Foliage’ mode that will allow your foliage instances to be accounted when the Nav Mesh is generated. Simply click on the static mesh actor while in foliage mode, scroll down to the ‘Instance Settings’ and set the ‘Custom Navigable Geometry’ to ‘Yes’ or ‘Even if Not Collidable’.

Now rebuild your scene to allow your Nav Mesh to be recalculated to account for your foliage instances that you have marked as custom navigable geometry.

Foliage Instance Settings

Foliage with Nav Mesh

Let me know if this was the appropriate solution, or if you are still experiencing issues.

Cheers,

Andrew Hurley

Hey Andrew,

This DID solve my problem actually, I’ve set it to “Yes” and I had to add UCX collision to my trees, AND restart the editor. The last bit was why I wasn’t seeing the changes immediately.

Thanks for the info and sorry if this is intended behavior and not a bug report.

Best regards,
Damir H.

I second this, i just had to use that setting and then restart the editor. Before restarting, no changes were shown.

In UE5 it´s even with “CustomNavigableGeometry” not working…
(It´s activated by default)

Hey there @Killerzwerg! There is a new issue where foliage isn’t effecting the nav mesh. It has been fixed for the 5.1 build that’s coming. Unreal Engine Issues and Bug Tracker (UE-150147)

Thank you ^^

1 Like