Download

Bug ? All the project's visuals are gone.

Hello community !

I was loading my project I was working on. Left it for a couple days, no problem.
I was surprised to be welcome by an empty scene. Well, not quite empty, everything seems to be here but not visible.

Triple checked that nothing was hidden. All my levels are displaying the same thing, empty scene visually, but the stuff seems here in the outline and viewport.
I should have a sky, a floor, a few meshes and materials displaying in the scene, noting too complex but still, a real scene, not an empty void.

Also, look at the icons of lights and elements : they seem scaled down to a plane, or rotated but not the usual way.

Starting a new project is fine, but all my levels and new levels in that projects are corrupted in the same fashion.
Needless to say that it was fine when I closed and saved it a few days ago.

Some insight about what happens ? Or any tip about how to fix/avoid that ?
I would like to avoid doing a new project and copy paste stuff just because Unreal decided so.
(I know it’s unreal 5 and I use at my own peril, but still)

Hello!
Same thing? Or at least very similar?

*I’m using World Partition, are you?
*New maps etc. are corrupted in the same fashion?
*Duplicating your level gives you an empty or nearly empty map even in the outliner? Same with using an autosave of the level from before the corruption, right?
*Haven’t tried starting a new project yet though, but I did reinstall/rebuild the engine source code to no avail.
*Does playing in PIE work totally fine? It’s just the visuals in the editor right?

***I’m going to reinstall the engine source code from scratch tonight on a fresh drive I just bought, and delete unneeded/generated project folders (saved, intermediate, etc I forget the ones exactly) and rebuild its solution. I’ll let you know if this fixes anything for me.
Update: This did not resolve anything! I also get this crash when I pin everything and try to play my game while it’s all visible again in the editor, but do not get this crash if I just play while everything is “hidden”. Have you been getting weird crashes as well?
animblueprintclass_fail

I didn’t get the scaled down flat plane thing for the “remaining” actors though, that’s strange.
Try the outliner pinning thing I found in my post, I wonder if you get the same results? At least it’d be reproducible behaviour then.

I hope we get a dev reply on this alarming bug soon…

Hey !

  • no world partition
  • Everything I do in this project is corrupted the same way yes.
  • I have entities in the outliner, just nothing on screen except icons
  • haven’t tried this yet
  • I don’t see anything while playing :frowning:

I haven’t noticed any crash really. Outliner pinning ?

One thing I’ll try this weekend is do a new project and copy paste my content there. I know it is a band aid but… yeah

Dang, not sure what’s wrong for you.
I managed to solve my issue. World Partition “unloaded” all the cells automatically (a bug I guess) when the editor spazzed. I managed to select all the cells and right click and click Load and now mine’s working.

Re: outline pinning, there’s a way to pin actors in the outliner. I guess with World Partition if that actor is unloaded, pinning it temporarily loads it in which is why it was showing that actor for me when I pinned it.

Hope you can solve your issue!

Good for you !
Yes it’s weird I don’t have that.

What I did though, was to create a new project, and copy its content back into the old project. Turns out something got replaced right and now the maps are as good and non corrupted as they were.
Hopefully my project was very simple, it’s not a game or anything but a simple render scene, so that seemed to work.

thanks !