Download

BP UMG Menu System 4.7 /w network

I, like many others, have been fiddling in Blueprints trying to get a main menu system, with in game menu, and network host/join all set up. I have seen loads of examples, and I have watched that twitch feed where they show an example they did (which they have not released the BPs for). So I set about to take what I learned, as a UE4 noob, and try to put something together.

I have the network host/join stuff there, though I can not see the difference between having LAN on or off, same results.

I also am having a strange issue, when the game starts a single click on a main menu button is fine, takes you where you should go, but once you got to a different screen then back to the main menu, it takes two clicks on a button for it to work, like the first click is just setting focus. Any ideas?

I also set a check in the playercontroller for the ESC key being pressed to bring up the in game menu. Works… the first time you bring it up, but if you hit ‘resume’ so the menu closes, esc never brings it up again. Again, any ideas?

Anyway, screenshots:

Main Menu:

Join Server when searching for servers:

Join Server when no servers found:

Join Server when servers found:

Host Game menu:

The options and settings menus are just empty with a return to main menu button for now… Used a wallpaper and font I found on line to try to ‘spice it up’ a bit just to get people seeing everything does not have to look plain. :wink:

I could not find what the minimum stuff needed to pack up to pack up a project to share is, so I did my best but the .7z is still like 700+ megs. But I based it on the fps template that comes with the editor, and it additionally has the TPS body and animations in there and set up so you see arms, but other players see the full body.

Tried to put it on my dropbox, but that is running painfully slow, uploading somewhere else and will edit with a link when it’s done.

Here is the file…

BP_MPMEN_FPS

forget that one, too big, got rid of loads of stuff, down to 11 megs:

nice work will test it out later

Hey cool … thanks for this … about to start this for my project … heheheheeheheh … much appreciated. 8-}

If anyone can figure out the double click button issue… or knows how to better capture the esc key when in game to bring up a menu and have it actually work, let me know.

I’ll have to download it and give it a look over some free time. Thanks for sharing ! :slight_smile:

This looks pretty cool. Not going to be downloading yet at 600mb though. :stuck_out_tongue:

As for the double button click that’s caused when you have multiple buttons/widgets stacked on top of each other. Double check how its getting added to the viewport and make sure multiple aren’t getting added.

Thanks for sharing, as for reducing the size of the download, you can leave out the Saved and Intermediate folders. Also you could leave out Content\MandT, this reduces size considerably but the example level will be plain and boring.

There are 3 nodes about focusing on blueprints, I’ve encountered this problem before and almost gone crazy about it :slight_smile: You can search for set input mode (Game only) (UIOnly) (Game and UI). Btw thanks for the project man. This is great contribution to community.

Thommie, yeah, I thought about the material and textures folder, thought I cleared the others.

theknoppix, yeah, I messed with those. It seemed if I had a ‘path’ the blueprints executed where you hit UIOnly twice, it caused the double click thing. Oddly, when I compile down the ShooterGame to an exe I get the same behavior.

Ah, and it’s down to 11 megs…

When I get a chance I will be making some changes, I think I solved a few problems in a test version, just need to copy some of the changes over.

I understand after checking your project. Tried couple of things but it didn’t work for me too. It’s really weird that, on start it focuses on your main menu properly, adding other widgets to viewport doesn’t require any focusing action but starting the game from beginning (by making your main menu visible again) breaks everything nonsensically. And it only happens on return to main menu :confused: Still trying to figuring out.

I’m trying to debugging focus lost with On Focus Lost on umg classes. When i click to settings button for example, it loses focus from main menu. But without clicking any blank space on settings menu, returning back to main menu doesn’t lose focus on settings. But before returning, clicking to any blank space on settings menu focuses settings. I hope i didn’t tell it so complicated because of my english. Even though it doesn’t focus on settings, everything works properly on there. Maybe focus lost debugging helps you a little bit to solve this problem because i really wonder the solution.

Awesome contribution to a very useful feature for games that need multiplayer support! Keep up the learning!

@Theknoppix … I had fiddled with it a bit, and made some changes related to UI vs game control. And ended up setting it so it reloads the ‘main menu’ map, which seems to get it all working right.

Also have the ESC for the in game menu working properly.

Need to go back and add in error messages where appropriate, and perhaps rather than ‘main menu’ in the in game menu, change it to ‘leave game’ and provide a ‘are you sure’ answer, as going back to main ends the session…

Is updated on dropbox… Dropbox - Error

@Andrew, thanks.

@arbopa I’m glad you solved the problem even though it’s a little bit hacky. I’ll try to make same fix for mine because i don’t want to download again. Thanks again.

Yeah, even though it’s a level with nothing in it, you can see the delay when you hit the button. I will have to dig deeper for sure to get it figured out. Thanks for your input.

If you figure it out, let me know. :wink:

I made some other minor changes and added an error msg system… which now uses the built in network error system. Here is a screenshot … style could be improved… but, I had two instances running, a host and client… had client connected to host, then quit the host… the client quits back to main menu and shows the error message:

Really cool update again. Did you try steam overlay btw? Because there was a thread about that it’s impossible to use steam overlay on online games with blueprint. That guy shared his project too, if you make it offline steam overlay will appear, but on default it doesn’t. Are you planning to improve this menu with graphic settings?

I have downloaded the steam SDK as I read you can get a test appID for steam somehow. So I would like to try to incorporate that.

Yes, for the settings and options menus I want to have audio/video type settings, have not looked too much into that so far, I know Rama has made loads of additional BP functions that can be used, such as getting what resolutions the users card can handle… was hesitant to need to include his plugin. I know he also has one for altering your control keys as well… I will need to look a bit deeper into his plugin and see if that is simply the only answer for doing that stuff with blueprints.

thanks for sharing
when i try to join session (game) it tells me the error (error joining session)

Seeing this kind of project in forum is really good for me because my weakest knowledge is about menus :slight_smile: Really look into your updates.