Box collision does not recognize static mesh

i’m trying to overlap a static mesh with a box collision but, the box only recognize actors, how can i make the box recognize static mesh?? or will I have to create actors from all of my static mesh??

I don’t quite understand your question. Are you trying to know when you box hits your static mesh? Why not add a collision shape to your static mesh and check against that?

i’m trying to use box’s “event begin overlaped” but this event does not recognize static meshes

It’s usually one of two things. Maybe both!

  • Your static mesh doesn’t have a collision box.
  • Your collision filtering isn’t correct.

my collisions are all ok, but anyway, the overlap event of the box does not recognize static meshes

So I have been researching this for a couple hours and the problem is in each individual static mesh’s collision. It’s literally a button that says “generate overlap events” and it’s off by default, so just turn that on. I have no idea how to make it a default setting to have it on, which it should have been in the first place.

1 Like