Box brushes disappear after lighting build

My Box brushes disappear.
Please help me.

And the lightning building proces stays at 0%
btw this is just happening since today.


Hello shadeslp,

So from what you describe you created a box BSP brush and you had it set to additive. Before the light build you can see your brush.

If you lighting build is stuck at 0% how are you seeing your brush “after” the light is built?

Please let me know if this is what you are doing.

Also if you could link me your DxDiag.

After I have this information I will continue to investigate this issue for you.

Thank you,

The lighting build worked before once and now it is stuck at 0%.
And as i said i only have this problem since yesterday, weeks before it worked perfectly
link text

Hello shadeslp,

There have been multiple lighting bugs ranging from being stuck at 0% to 80% and other random values. We are currently trying to lock down exactly what is causing this issue. It has been reported across different computers and computer specs so it has been exceedingly difficult to track where the problem is originating.

As far as the BSP not being build goes, the build button also builds geometry. If you do not build your geometry once created it will not appear as you would expect it to.

I have a few troubleshoots for you :

1.) Can you create this in another project ?
2.) Can you recreate this in a blank project in 4.9?
3.) Have you made any changes from yesterday to today? If so can you go back to what you changed? Does that fix the issue?

If you are still having this issue I can try and recreate this ins a controlled test project. Do you have any reproduction steps for me to try and recreate on my end?

Thank you for the 3 troubleshoots i will update the program to 4.9 tomorow
and give you a statement if it works

and i am also sorry for my bad english it isn´t my native laungaue.

I tried somtihng similar in a diffrent project and there wehre no problems.
Is there any way copy the structures of one Level into another ?

You can copy a Level from one projects directory to another.

But i encounter this problem only when i load this level.

You can convert your BSP brush into a static mesh. After that you can migrate that particular asset over. You can also do this for any other BSP you want to migrate.

The only other option, other than transferring the entire level which won’t work in this case, is to recreate your assets in a new project.