Blurry, noisy, lighting and shadows are messed up

Hey,
I have no idea how to describe my issue. A video should tell everything.I don’t have any experience in lighting. :')

I basically have a single rect light, very large, which has a lot of indirect lighting,(the scene itself is very big) and set as movable, a post process volume with min and max brightness set to the same number, auto exposure disabled. I also chose to turn anti aliasing off for the moment (but I’m convinced it’s not the issue)

I’m trying to make a game full of non sense (and I’ve done pretty great I guess) but … this is too much.
There are so much things I don’t completely understand despite the fact that I’ve watched many tutorials. Has anybody an idea of what I should change ?

Can you show your material ?
Is the real time ray tracing enable ?

The material is just a vector parameter 0.0.0. nothing else. Ray tracing is not enabled

Very Intresting Game

1 Like

I think it due to the way lumen updates the scene. It calculates the light in an accumulative fashion (that’s why you can see ghosting in scenes with rapid camera movement with lumen).

Try stitching to non lumen gi and see if baked lighting fixes this issue. Maybe some tweaks to lumens settings could help.

This is typically one of two reasons:

  1. You built your scene out of BSP brushes
  2. You imported your scene all as a single mesh

Post screenshots of the Lumen debug views, it’s not worth trying to help without them

How can I see lumen debug ?
And my scene is separated in several meshes

Thanks. It looks really strange … The ceiling seems to have strange stains that are constantly moving, and they disappear when the camera gets close.
I hope you can see that on the video.

Do you have screen space GI turned on by any chance? (it’s experimental)
It seems like it’s only calculating the bounces when they appear in screen space.

No … I created another level with different meshes, but this time by keeping the sky and directional light from the basic template. It still looks very grainy (also, i have a small motion blur even with the option disabled in project settings)

what does the floor look like in the lumen scene?

Completely white, like the walls. But it’s actually the same mesh duplicated

And where is the light coming from in this room?

A huge rect light covering the place. HOWEVER, it is placed BELOW the ceiling. But the issue occurs with the whole scene. Moreover, the scene acts like auto exposure is on (sometimes it gets brighter, sometimes darker) even if it’s off.

I’m pretty sure it’s not a good way to light up a closed scene like this so if you have any other suggestions…

I also tried to increase the value of indirect lighting smoothness in the world settings but it changed nothing

Another example, on the ground :slight_smile:


It’s extremely grainly and it looks horrible. It maybe comes from indirect lighting of the rect light (set to 2000) because it’s a huge number ?

EDIT : so I tried to set the indirect lighting back to 1, and increasing significantly the intensity … and the problem seems to be gone. But I think it is because of extremely high numbers in lighting (intensity, rect light scale, indirect lighting)

Nobody able to help me ? :confused:

Add Thickness to the walls this worked for me in Blender and in Unreal too

Sounded like you already fixed it by changing the indirect lighting intensity?

I have made many more tests. It is actually due to the way lumen works and the occurs even when indirect lighting has 1 as value. But I’m now searching for settings to change in order to get a good looking result …