Blueprint pivot point

Hi everyone
I am working on a plane project and I have been running into an issue lately.
When I try to rotate the plane, it rotates from a pivot point under plane itself which gives it a weird effect.
This is my blueprint:


Does anyone know how I can change the pivot point inside the blueprint itself?
Thanks for the help

You just need to move everything in the blueprint so that pivot ( which is at 0,0,0 ) is in the right place.

2 Likes

you can use a scene component as the parent and adjust all children relative to it. I may be saying same thing as clockwork ocean but am not sure so figured i’d chime in.

2 Likes

I can’t move the box collision down since it’s the root, I tried moving the rest but that didn’t fix it, got anything I can do to fix that?

3 Likes

I can’t do that because it needs to simulate physics, I tried to but it didn’t work :frowning:

Do you have the 3D Model as OBJ or FBX or anything similar?

If yes - import it in a 3D Modelling Software, move to the Center as you need and the Center is the Pivot Point

Export from 3D Modelling Software and import to UE4 back - now you have your mesh as intended

Edit: Or wait… :thinking: you mean the whole BP pivot point? it’s always the Center where the Root is

Why do you want the Box as root?

You can f.ex. use the Plane and its collision (if it doesn’t have any you can generate it in UE)

Or do you have any particular reason for that setup where the box is the Root Component?

But if you just rotate the Plane then I assume the Plane itself has Pivot Point underneath so you probably need my 1st idea solution :slight_smile:

Also be aware that if the Box is not moved and it’s the Root - it’s always gonna stay in Place

Is that intended? Actually you could use that as the landing point afterwards as an example :stuck_out_tongue:

1 Like

the reason the box component is root is because I can’t use the skeletal mesh as root for the reason that I can’t add a force to it or it will give an error, so that’s how I fixed that error and now it works. If you know any other workarounds, it would be greatly appreciated.
I wonder why epic hasn’t added this yet.
And no, sadly I don’t have an OBJ or OBX file of the plane…

image

Read the middle line

If I select the existing “Skeletal Cube” it’s disabled
image

But if I select the “SK Mannequin” it is available:

And this is because your Plane doesn’t have Physics Collision setup, it looks like this:

And you can get there just by double clicking the Skeletal Mesh

I hope that clarifies it :slight_smile:

1 Like

Yeah I tried that and I can enable physics, but as soon as I use the addforce node, I get an error and everything stops working for some weird reason

Then double click the Plane Skeletal Mesh and tell me if:

A - it looks like this:
image

or B - like this:
image

Top Right corner

I’m currently using UE5 but when I double click it it looks like this:

In the Plane BP - what is the Collision Preset for the Plane Skeletal Mesh?

It should be PhysicsActor in your case
image

Look, I made my guy flying while having physics on xD

And that’s what I did to him:
image

And If I select the Bone to Head he will ascend to the Heavens XD

It’s currently set to nocollision, I tried the others too

No Collision returns error “Physics enabled but collision incompatible”

When changed to PhysicsActor it should work as intended

Make sure you select the correct bone IF none (Root) isn’t what you need

If there’s no - you can add own :stuck_out_tongue:

I’ll come back to this tomorrow cause it’s really late right now, thanks for the help!

1 Like

No problem

Just please give a feedback after all, or just ask if you’re still stuck

Wish you best of luck! Although it’s not as hard as you thing - it just exists and works only when some rules are met, that’s it ;]

1 Like

Hi again, I just removed the box again, set simulate physics to true on the skeletal mesh, changed the collision to physics body and tried to specify a bone for the addforce and addtorque node, I get no errors but physics don’t seem to be working, did I miss something?
when I remove the bone from the nodes, I just get an error that physics need to be enabled.
I’ll try some more stuff now.

Edit: I’ll try copying the code to the mannequin

I found out it’s definitely the plane because it works fine with the character untill I change the skeletalmesh to the plane, and it just doesn’t work anymore

I managed to make him stand up just by adding a force to his head :joy:

You’re using UE5 unfortunately, and you don’t have the Plane Model as ‘raw’ model

If you have UE4.26/7 - migrate the Plane to such Project and send me the UASSET file

Here’s some Rigged Plane for free, maybe it will do

And some tutorial (UE4) on how to add Collisions to Skeletal Meshes which is a mandatory for physics to work

Although for UE4 - the principle should be pretty same as for UE5, it may be that you just have to look for some stuff in different areas :stuck_out_tongue:

1 Like

Be careful with UE5 and simulate physics, it’s bugged and the fix is planned for 5.1 release.

To make an example of what I’m talking about: Move Objects On Conveyor Belt UE5

2 Likes