Move Objects On Conveyor Belt UE5


I recently used this tutorial to create a simple conveyor belt in UE 4.27, and it works exactly as expected. When objects (with collision, overlap events, and physics all enabled) land on the belt, the objects move to the end of the belt.

Today, I upgraded my project to UE5 because I was waiting on some plugins to get updated to 5, otherwise I would’ve just started on 5. But, it seems this method of conveyor belt no longer works in UE5, or something has changed that I’m not aware of. What happens now is any object with physics enabled lands on the belt and immediately stops moving as if the belt has extremely high friction. I’ve also tried to start with a blank project just to build the conveyor belt and test with a static mesh cube, and the same thing happens (video below). But works perfectly fine in a blank project in UE4.

If physics is not enabled on the objects, and I just float the objects over the box collision of the conveyor belt, the objects move along the belt as expected. But there’s obviously no physics on the objects and they’re now floating above the belt.

Here’s what happens with physics disabled/enabled. But I would expect the cube to move on the belt regardless of physics state.

My conveyor blueprint

My ultimate goal is to have multiple objects drop onto this belt over time, and once they’re done bouncing around from physics, the belt will carry them along to their destination. Any help is appreciated. Thank you :+1:


I’ve tried installing UE5 on a different PC and building the same solution, but I still get the same result of physics objects getting stopped once they touch another mesh. But it works as expected in UE4.

If you got it working in UE5 could you possibly send me your .uproject file so I could try it out?

EDIT: The closest I can get this to working is by cranking up the speed variable for the belt. The objects fly down the belt but then end up all jittery once they’re off. But if I want a slow-moving belt, it can’t be done - objects get stuck to the belt. Testing this on two different PCs and getting the same unintended results leads me to believe that something has changed between UE4 and 5.


You might have to excuse me, I tried again using a static mesh and it has the same problem of your project (Previously I tried placing the ThirdPersonCharacter thinking that it had the physics enabled by default, but it doesn’t, it’s just affected by gravity)

I’m trying to dig deeper in this, if physics is enabled it has problems even setting the actor location (not only adding world offset).
I’m really sorry for the assumption I made in my previous post!


Hey, no problem. Makes me feel better knowing that you’re running into the same issue. I’m still trying different methods to get this working but haven’t found anything yet.


Hi there, I encountered this issue too in UE5 with the same tutorial! So I found something that works but I don’t know if this is the right way to do it. I added a “RadialForce” component to the conveyor belt blueprint and my cube moved. First I had to set the object type to “Physics Body”. Wasn’t perfect though. My banana moved but it was jittery.

1 Like

I reported this to Epic and they have confirmed that it is a bug. The bug report can be seen here:


I had similar issues, but got no replies at the time.

Has a work-around been found for this yet? I see that the issue is still unresolved.

Nothing official yet, so I’ve been working in UE4.27 in the meantime. Their target version for a fix is 5.1 which is a minor version, and that could take months before it gets released.


I’ve encountered the same problem. I have an entire project upgrated to 5 and i need this to work again. Hope it will be fixed in 5.1.

Does this work as an alternative for you?: (813.6 KB)

1 Like

Normally, all issues between physics and overriding physics are due to the fact the object root is wrong / it has no collision or similar.

Try making the box into a blueprint, and assigning the cube as the root.

If that alone doesn’t fix it, then simply disable physics on impact/collision before you start to move the object.

Its a workaround at best, sure. But you don’t have many other options if you want to continue to use the sorry excuse of an engine they are peddling this year…

I can confirm it’s finally working in UE5.1!


It worked for me, thanks!