Bloom effect out of control

I created a Blueprint for the car I’m working on, however no matter what I do I cannot get the environment looking even remotely ok. The bloom effect is totally out of control no matter what I do. I only have an HDRI backdrop, directional light, exponential height fog and volumetric clouds. In the post process volume in my scene I minimized the bloom effect as much as possible but to no avail. The default value blows the whole scene up. Any suggestions? Thank you.

Does this help? It is pretty well documented.

Thank you but it doesn’t really solve any of my issues. I deleted the PostProcessVolume and created a new one. Disabling the Bloom effect in settings simply removes it, but I want some bloom just not to this extent. Not really sure what to do at this point.

What have you tried so far?
Intensity: (0.3).
Treshold: (10).
Bloom convolution: (Disable.)
Dirt Mask: (Disable).

Since the sky is also very bright, I think that the eye exposure post processing setting could be affecting this as a whole as well.
Lens->Exposure->Min Brightness (5).
Lens->Exposure->Max Brightness (5).

Sorry if this is a dumb answer, but is it not just the Lens Flare that is cranked up too much?