Blocky shadow rendering artifacts

I’m encountering weird shadow artifcating with dynamic shadow and directional global light (Skylight, Sun) I can’t figure out. It is not a resolution problem.

Current setup:

r.ShadowQuality=3
r.Shadow.WholeSceneShadowCacheMb=300
r.Shadow.MaxNumFarShadowCascades=10
r.Shadow.CSMDepthBias=20
r.Shadow.CSM.MaxCascades=6
r.Shadow.MaxResolution=1024
r.Shadow.MaxCSMResolution=2048
r.Shadow.RadiusThreshold=0.02
r.Shadow.DistanceScale=1.4
r.Shadow.CSM.TransitionScale=0.8
r.Shadow.PreShadowResolutionFactor=0.8
r.DistanceFieldShadowing=0
r.DistanceFieldAO=0
r.DFShadowQuality=0
r.AllowLandscapeShadows=0
r.HLOD.ForceDisableCastDynamicShadow=1
r.VolumetricCloud.ShadowMap=0
r.SkyAtmosphere.SampleLightShadowmap=0

I know I can just crank up r.Shadow.DistanceScale to astronomicla values (1.4 is already INSANE) but this is not a realistic solution. There has to be a way to reduce this blocky flickering.

Hi @anonymous_user_5d045ead!

I see that you do not have distance field shadows enabled. This has been known to reduce or eliminate shadow flickering and increase the quality of shadows as well. This may be what you are looking for:

Unreal Engine Forums: Using Distance Field Shadows

I hope the above solution works for you!

Hey, yeah, I know what DF Shadows are and what they are for, for he most part they are essentially static shadow imprint and they are kinda their own thing separate from the cascade shadows. If I enable them they will overlay cascades and may partially mask the issue, sure, but wont actually address it. I have disabled them to make the issue more clear. It is still there even with DFS active, especially when sun/moon directional light source is low and tree’s shadows are angled in a form of a long shape on the landscape (i.e. way before DFS kicks in).

Bumping in case any shadow pros pass by.