black spots on my static mesh?

I recently bought a few assets from the marketplace.
I bought the Pirate Poylgon Pack by Synty Studios and I created a scene with it…
After the first lighting build my meshes got weird black spots on it…
I don’t know what this is and how to fix it… please help!

(I created a default map and didn’t change the lightning)

These spots appear to be baked shadows, increasing your lightmap resolution on the object or setting your bake quality to “production” should reduce those. Baking at production will be slower with more complex scenes

Thank you for your anwser! I already set the light quality to production and I tried to increase the resolution now and it’s reducing the black spots… but they are still there and this is annoying. There have to be a way to get rid of these spots… But thank you!

Hmm. It might help to switch to the “Lightmap Density” view to see if they are still somehow too large. Another option, given that this is an asset from the marketplace, it may need to have lightmap UVs generated for it.