Black spots appearing on static mesh

I’ve been trying to figure this problem out for a long time and it’s really ■■■■■■■ me off, so I made a static mesh of a brick wall in blender and exported it to unreal like usual, but when I built the lighting, it had black spots all over it. It used to be worse, the entire mesh was covered in black but I made it a little better by adding the lightmap in blender. This has been a problem for me for a very long time so please help, but thanks in advance.


The picture you’ve attached is still under build… how does it look like AFTER it?
And as you see your lightmap is not ok!! …I guess it’s an automatically generated one and where you have the seams you have the black artifacts…
I guess having a proper lightmap would solve your problem!

Good luck!

Generally, when you have black ‘spots’ on the mesh, your lightmap could have problems with this. The errors you are receiving means that your mesh hasn’t been properly UV unwrapped in Blender. Make sure that you have no overlaps on your UV before you export from blender. You will also need to make sure that your UV islands have enough space between them that the lightmap doesn’t bleed over onto a nearby UV island.

Because that is a wall, it’d be easy to just planar map it to make sure your UVs are correct.

Other reasons you can end up with black spots:

  • Lightmap resolution is too low. The default lightmap resolution on a static mesh is 64. If the mesh is large, you need to increase this to 128 or 256 and rebuild the lighting. It will get rid of black seams (usually where two meshes overlap or connect).
  • You have enabled distance field ambient occlusion and are getting artifacts from it.
  • You are using a material that is creating artifacts (such as incorrect blends)

Can you link to a video tutorial on how to do these because nothing seems to be working, especially now that I’ve baked a lightmap only to find out that you cannot import baked lightmaps into ue4.

What did you bake your lightmaps as? A .jpg texture? You can still import those. Set the .jpg texture to the ‘emissive’ part of your material. It will not receive shadowing from the light but it should still work (I’ve done it before).

To change your lightmap resolution, you need to click on the static mesh you imported, and navigate to the setting titled “Override lightmap resolution.” Change the number to 256 and try again. I posted an image below of the setting:

I’m not sure how to UV map in blender, I only use 3ds Max. I found this link that talks about the basics of UV mapping in blender (this should help with overlapping UVs).

When I add the lightmap into the material as the emissive, it changes the outer appearance of the whole material, acting like its the diffuse