Black screen when playing on editor.

I’ve downloaded a project (Supermarket) from the marketplace because I want to use some of it’s assets in my project.
Also the landscape and light setup.

I duplicated the Supermarket main level, in my copy I deleted everything but the assets I need, and clean it for export. The level works perfectly in FPSmode. Then I migrate the whole level to my WIP project.

Back to my project, the new imported level renders perfect on viewport, but I get a black screen on play (view or standalone).

Things I’ve tested:

  • I’ve dropped a FirstPersonCharacter in the level and it’s camera seems to render ok.

  • Tried to delete al postprocesses, in case my black screen is a zero exposure rendering for some reason.

  • Tried to override the GameMode to First Person in the world settings,

If I could tell the engine to give me a play on wireframe mode, at least I could know if the geometry is there or not, but I don’t know how to do that.

I guess this must be the most simple thing that I’m missing. (Again)

Any help?

UPDATES:

I can confirm threre’s geometry in the playgame, I know it because if I move (in the dark) , when I press Esc to stop the game, the editor view is in the position I set playing. So it’s a visibility, camera, light, or postprocessing issue.

If I create a new level (Default, or TimeOfDay presets) , it fails. Black screen. And another level I was working on is also failing since I imported this set. But, curiously, I have another level that keeps rendering ok. And the First Person Example Map works fine too.

Solved. I had a deprecated modification of the FirstPersonCharacter with bad exposure on it’s camera. My GameMode was spawning one of those instead of the regular, untouched, FPC.