Bad Reflections with Lumen on Translucent Glass

Hey there!

I need some assistance, it seems easy to solve but for me it’s impossible.

I have this project, i opened it up in UE5, and all I want to do is to set up a correct glass material.

In the Material editor it’s set to Translucent and Surface Forward Shading, but as soon as I set the Light mode the reflection quality becomes reaaaly bad.

Raytracing is enabled in the project settings, and in the post process I’m using Lumen for now, but if I set the Translucency to Raytraced, the object simply dissapears.

Can someone help me out here? It’s driving me crazy that I can’t have a simple glass material.

Also If I set the reflection to raytraced, basically nothing happens.

I believe Raytracing on translucent materials is a seperate setting. Try the command r.RayTracing.Translucency 1

Hi, @vidaandras!

If you are having issues with Lumen reflections, I know a similar thread where a solution was found to sharpen reflections in Lumen projects. Maybe this will help:

Unreal Engine Forums: Raytraced reflections not working in ue5?

I hope the above solution works for you!

Yeah so i turned it on and that’s when the object becomes completely transparent (opacity although is set to 0.5) I don’t know why it does that. Btw, it’s the Matrix city scene if you want to test it out!

Maybe they manipulated a project setting or the ini files, that doesnt let translucent raytracing or something…

It was super helpful this tutorial because a lot of stuff i didn’t know! but still none of these fixes the issue of literally making the object disspapear (not deleted, but as is the opacity was on 0) after I turn on Translucency Raytracing.

I treid to set up the same stuff in the archviz demo enviroment and everything worked perfectly with sharp reflections.

Hey @vidaandras!

I may have found another possible solution to your issue. Here is a non-Epic affiliated creator that directly addresses ray traced translucency in Unreal Engine 5.0:

Fixing Common UE5 Issues! Changes in 5.0

Hopefully this will be more helpful in resolving your glass issue.

I posted a similar problem thread a while back, an ini edit was a guess of mine originally, as the citysample was demonstrating non-standard engine behavior compared to other tests. It’s certainly fascinating, but the bottom line is: 5.0 does not support mirrored reflections on translucency. That feature, known as high-quality reflections, is only available in current github builds of UE5. I’ve pulled it down and worked with it, and it’s great, but I understand many projects either cannot afford the technical risk of using an untested engine, or can’t afford to wait until 5.1.

I managed to set up the translucency with sharp raytraced reflections in the archviz template file in Ue 5.0.2 just fine, all it needed is to turn on raytraced translucency and then the reflections are raytraced.

1 Like

Ah, you’re right ; I should clarify: you can’t use lumen to get sharp reflections on translucency. RT translucency works great, but last I checked it does not support shadowed skylight or GI in reflections, so I avoided using it for light leaking reasons. It does support more advanced features like realistic refraction, but it can also do strange things to content on account of functioning much like the path-tracer. You are correct.