Bad Performance with Lumen and Virtual Shadows

There is a problem with version 5.1 with the performance.

Lights that are behind a wall and are completely obscured still seem to cause a huge FPS (around 70 to 15 FPS) drop. I’m using the default settings of a new project (Virtual Shadowmaps, Lumen…).

I have created completely closed rooms, when I look at the wall where the entire map is behind with about 70 dynamic point lights (All in other rooms and never visible at once), it immediately starts to drop the FPS down. The point lights are also located in closed rooms and are not visible from this room. With version 5.0 there was not such a big FPS drop.
If I switch the point lights to invisible, the FPS immediately increase again. The occlusion doesn’t seem to work with lights.

I just have to rotate the camera in the direction where most of the lights are behind several walls and the FPS drop immediately, if I turn the camera in a different direction where are no lights at all or only a couple of lights, everything will run smoothly again.

It may be due to the virtual shadowmap, which has been revised in version 5.1, or it is lumen itself, which does not take any occlusion into account.

Thank you!

Best regards!

Occlusion isn’t really a thing with unlimited bounce global illumination. Any light, no matter how occluded, could potentially make it into the visible scene. There were lots of changes to these features so it’d be hard to pin down exactly what is causing the loss of performance in your case without doing actual profiling.

But a good start would be disabling each feature individually to see which one is actually responsible. You can also set a max draw distance for the lights so that once you’re far enough away they stop rendering.

There are a lot of ways and settings you can use to improve the situation, but unfortunately I don’t think relying on occlusion is one of them.

Use the profiling tools

it looks like the virtual shadowmap needs some performance, if i disable the virtual shadowmaps i already get better performance.

If I deactivate the global illumination, the FPS does not increase at all.

But I don’t get anywhere near the same FPS as with version 5.0.

I have checked what is causing the performance to drop. it looks like the dynamic shadows (although none are visible) are affecting performance so much that it’s under 20fps.

Nanite with the virtual shadowmaps requires almost as much power as all point lights together (used profiling).

5.1 doesn’t look any better than 5.0 in my scene but needs 4 times the performance.

1 Like

Same to me 5.1 has some problems with ligths, i just added 1!!! spot ligth for head ligths of my car BP, and have lost 70fps!!!, gone from 110fps to 40fps on average, all in a new open world default project, and low scalability, with amd 5700xt 8gb oc, 32 ram, ryzen 7 2700x

Curiously, ray traced shadows are better and perform better than virtual shadowmaps, if you want to give it a try.

thansk, but sadly amd card it’s not capable of raytracing

AFAIK you are wrong. Only old ones can’t do it.

AMD 5700XT does not have hardware-accelerated ray tracing, i learned the hard way, because it comes with RDNA arquitecture , i’m saving to build a new computer with RTX card

Exactly. I think they are RT capables since the 6000 series. But yes, I also prefer Nvidia for this purpose.