Download

Auto Exposure issue ?

Hello.
I have a pretty basic setup in 4.26 - an import from Revit trough Datasmith, a PostProcessVolume, LightmassImportanceVolume ( both of these pretty much cover around the Revit object ), and SunSky and a few PointLights ( set to Static ).
The issue is that I cant find a way to turn this Auto Exposure thing which is pretty much obstructing the workflow (and finding it actually strange to be on by default )…
As well - the PointLights doesn’t seems to do anything with this setup, and I am not sure why.
Please help.

This screenshot is from video about old version of the engine. There is not such field in 4.26.

It is very much still there in 4.26

I dont see such…

Because you enabled extended luminance range which replaces min/max brightness with min/max EV100… they do the same thing effectively, just set them both to the same value and you will have a fixed exposure.

Well… I did not enabled anything. I am using the basic template with the hope that these things is solved there for archiviz works :expressionless:
Stetted these settings now both to 1, anyway not sure if it works, since everything inside is illuminated somehow, and none of the pointlights seems to actually works.

It actually went from bad to worse. I’ve run it just to see what’s up, and now it’s pure white.

if i am not mistaken, then this is auto enabled in any new project since 4.22, at least it was mentioned in the release notes for 4.22:

However, if you suggest a fixed exposure, wouldn´t it be easier to switch the “Metering mode” to manual and then use the “Exposure compensation” below it to find the sweet spot, for this scene?

I am more than thankful for your answer, anyway I am not sure how to fix this. Could You please give me guidance ?

I am talking about that setting in your list :slight_smile: Activate the Metering mode, and switch it from “Auto Exposure Histogram” to “Manual”, then activate the Exposure Compensation, and move the slider until your scene looks right.

Hint, for me, sometimes it´s jammend and those settings and sliders won´t react. If that happens to you too, then go into the project settings and search for auto exposure and turn it off there too, then those settings and sliders should work again (maybe a restart might be necessary).

However, i have the feeling, that you have one particular light in your scene, which is so extreme powerful, that other normal lights are way to weak in comparsion to have any impact on that scene, and your now completely white scene seem to confirm that ^.^ You mentioned, that you have a SunSky imported. Those contain a directional light, which usually act as the sun, with sunlike settings for their brightness, intensity 75000, if i am not mistaken. Just for comparsion, a regular light that you bring into your scene is usually set to 8 or 10 :cool:

So what probably happened in your scene, your auto exposure is adapting to your way to intense directional light from the SunSky actor (because its a literal sun), making it impossible for all your normal point lights etc. to have any noticeable impact. So you should first reduce that SunSky directional lights intensity to match it with the other lights (or turn it completely off for testruns).

Definitely isn’t true if you are making a game project, they still default to extended luminance being disabled, even the blank non-template project.

Wasn’t my suggestion, I was just confirming that the setting does indeed still exist. My opinion is that no one should ever disable auto exposure unless they know what they’re doing, they’re almost always creating more problems than they are solving. In response to switching to manual, yes that would be easier but it really only saves one step, because you can still use exposure compensation in histogram mode to adjust a fixed exposure after you’ve set min/max to the same value. Again though… no one should ever use a fixed exposure unless they know what they’re getting into…

Yeah! I’m in the same boat. Maybe one thing could change the exposure speed up & down values. So, it will switch faster while you are working.

But make sure to change it back to default or reduce it before you ship it.

Looking at this, I think this user is having some other issue.

setted the things to looks like these setting but it all looks like white… been stuck with this issue in the past two weeks, and i really not understanding what should I do.
Please help. ( step by step if possible, to see what I am doing wrong )

This is my current workflow as I understood that I must use so far.
The engine is 4.26.1.

Here my current workflow :

what does it look like when you reset min/max ev100 to their default values

Going by OP last post, It seems like the default values are wrong for a default project.

@OP, before continuing, try to verify the engine files.
if you have mistakenly modified the curve or some other file thats engine wide this may explain the problem and resolve the issue.

If the issue is the same after the files are verified, then this should probably be reported as a bug.
the issue here though is that your last image contains things. What does the scene look and render like before you import things?

if it looks washed out, its a bug with the settings. If it looks OK, you probably have something wrong within whatever you are importing.
don’t ask me how an import can override the sun and sky actor. Of that I have no idea…

The engine files are fine, he’s not using the default values.

With SunSky you need Min EV100 set to at least 12, to get a normal view. Everything below will be just to bright. OR, with your current values, set the Exposure compensation to -4.

I am lost.
I was following what the previous posts said to set as correct values, and now I read statements that they are wrong.
Please tell me from what kind of template i shall start, and which things to set in order to make the auto exposure go away and get normal skybox lighting :’(