Download

Augmented Reality for UE4

For multiple NFT markers, just edit the level blueprint and check all of your markers visibility with the get marker node in the tick function. Once a markers is visible use it’s vectors/rotations for tracking your camera or subject.

Hello, I bought a personal version of the plug-in, did not pack it out, there is no way to put other people’s cell phones? Do I have to buy a commercial version?

Hello,

Personal version is working on cell phones (Android / iOS).

Please follow the steps described on the link below:
http://www.unreal4ar.com/getting-started-full-version/

If you still have issues please get back to me with log files.

Hi Adam, thanks for the reply. I think i am almost there. Made my own markers. Copied the bp AR-actor_touch. Changed this BP a bit and referenced this to my new marker. Everything seems to work the way i did below. But somehow the original is not updating the location. So once the marker is detected, the scene stays in one location. Have you an idea whats going wrong?

Hi,

I cannot see too much … Can you please send me a higher resolution version to info@unreal4ar.com ?

oh man i am getting really crazy :slight_smile: Spending hours and hours, but i dont get it running. It works a bit, but not good enough. Has anyone maybe a youtube/ walkthrough where he showes how you can use different markers for diiferent scenes? I can make my own NFTmarkers, i can make some Blueprints to show a mesh and connect this to that marker. But once i use more markers and scenes it goes wrong.
Simple i want this:
marker 1 >>> shows blueprint 1
marker 2 >>> shows blueprint 2
etc.
But when i copy the levelBP with the NFT markers, and change the NFT and the Blueprint it doenst work!

i am sorry, there i am again. Most other thinks are working right now. Very happy to get this almost done :slight_smile: But the final step is the package to an .APK. That’s not working. Do you know this is a commen problem?, and i miss a very easy step (i hope). I tried to package a fresh template of UE4 (mobile, thirst person), and that packages allright. (both ue4.18)
here is the log:

Can you please re-upload the file ? When I click on the link I get [FONT=courier new]{“success”:false,“error”:404,“message”:“Not Found”}

Hi! Adam and everyone, I am wondering if the 2D barcode markers are working for anyone? it is not working on UE 4.18.2. Thanks!

i am sorry, here is the file again. Really hope you see whats going on, why i cannot this to a.apk file!
https://ufile.io/eentx

Hello,

[FONT=courier new]LogInit: Display: LogBlueprint: Error: [Compiler PersistentLevel.ARToolkitSimple] The current value (NewEnumerator35) of the ’ Enum ’ pin is invalid: ‘NewEnumerator35’ is not a valid enumerant of ‘<MarkersNFT>’ from Source: /Game/Maps/ARToolkitSimple.ARToolkitSimple:PersistentLevel.ARTool
kitSimple

Can you check this ? It’s located in the level blueprint of [FONT=courier new]/Game/Maps/ARToolkitSimple
Maybe you are not using this map at all, but you cannot pack the full project because of a missing value.

Hi!

Please check the init node, it has a parameter

  • Detection mode [EDetectionMode]: Template Matching Color – Fiducial markers (like Hiro or Knaji), or Matrix Code Detection for 2D Barcode Matrix markers

http://www.unreal4ar.com/init/

Change it to** 2D Barcode Matrix markers**.

thanks Adam, that helped allready a lot! it worked (and had to delete the whole folder of kitedemo too). It does package, but this is still red in the log:

LogTemp: IPP ERROR: Could not find provision directory ‘C:\Users\rober\AppData\Local/Apple Computer/MobileDevice/Provisioning Profiles/’.
Weird i dont use any apple devices, so something is allready set in the BP.

if the distribution tab is checked for google playstore, then the package failes btw. But that might be a whole different problem nothing to do with your AR template

Thank you, you beautiful soul :slight_smile:

Hi Adam! Is it possible to compile it to an iOS device directly from Windows UE4? Thanks!

I don’t think so. You will need a mac to do that.

Hello, I hoped you could help me with these problems when packaging, I get about 500 in the Output log, they are all relating to the ARToolKitBaseAdvanced and custom pawns I have made based on the sample classes

I am using engine version 4.18.3 and plugin version 1.7, however I did compile for engine 4.18. At least I think I did…

Hi, Adam and everyone. I am getting ‘webcam init error’ with unreal4.18.3 with iPhone 7, I have added the string on additional PList. Please let me know if there is any fix for that. Thanks in advance.

Hello,

Plugin version 1.7 is not working with with 4.18.3. You will need the latest 1.10 version. Please send me your order id to info@unreal4ar.com and I’ll send you a new download link for the updated version.

Can you please send me your device log ?