ARKit cook on the fly from Windows : no camera image


I recently upgraded my ARKit project to version 4.27.1 from 4.26.2. My usual workflow is as follows :

The project is installed on my Mac and on my Windows. I deploy it on my iphone from the mac without cooking, and I put the ip address of the Windows with the launch option -filehostip=x.x.x.x . Then I run the cook on the fly server on my Windows with the following command :

-run=cook -targetplatform=IOS -cookonthefly -iterate -debug -log

and then I launch the app on the iphone.

Everything worked fine this way in 4.26.2, but in 4.27.1 the ARKit camera image doesn’t display anymore, instead there is a uniform yellowish color instead of the image :

Tracking and plane detection still work without issues, it seems to only be a rendering problem. I have been able to reproduce the issue on the new Handheld AR template, as you can see in the pictures above. I have tried fiddling with the AR session settings and with the settings in Platforms > iOS > Rendering, to no avail.

I have tested this on an iphone 7 and an iphone 13 pro running iOS 15, with the same result on both.

Everything still works if I cook by the book, or if I cook on the fly from the Mac, so cooking on the fly from the Windows machine seems to be what causes the issue. I can’t really do otherwise, as cooking from windows really speeds up my workflow…

[Here is a part of the device output log when I launch the Handheld AR template on the iphone 13 pro with the setup described above.][3]

I’m not sure whether the line LogMetal: Error: ComputeEncoder: Prologue ARKit Video Texture Conversion has incorrect fence waits (0) vs. updates (1). has anything to do with this, as it doesn’t appear in my other project which has the same issue.

Thanks for your help !