Download

Anyway to edit the contents of a level without opening it ?

Using 4.25, having a problem with the maximum amount of reflection captures I can use, varies in project.

I was editing a level and put in approximately the 10th spherical capture. The program crashed.

I spent along time on this level, and now I cannot open it because of the last reflection capture I placed.

Is there any way to remove that reflection capture before opening the level ?

Thanks

There is a dirty solution to this. I just found it and I’m lucky the level in question does not open on start up.

  1. Open unreal, and click raytracing off and restart.

  2. On Restart open the bugged level and while the shaders are reloading select the capture and delete it.

I got my level back, it wasn’t the 10th spherical it was only the 8th, I have 7 remaining I dare not place more.

These spherical captures. I don’t think I am using them wrong. I just tried to select my 7 captures and tried to move them to a sub level… If anyone else gets the error shown in the image on this page, it is not your video card, mines have 11GB on each. Its these spherical captures. (Back up your levels before using them while using Ray Tracing)

The spherical reflection captures shouldn’t be causing a crash, your level would normally have quite a lot of them. If you’re using ray tracing though, all of your reflections can be done with ray tracing if you want to use that option, though that’s not an option if you want your project to work on machines that don’t support ray tracing.

You are running out of memory allocating a texture though.
So, why not reduce the size of all textures in the project? Unless you edited the reflection captures to have a crazy amount of resolution, then something else in your project is using up almost all your video card resources.

Thanks

Your right, I think I have pushed my build to the limits. I checked the GPU usage. It spikes fast when doing something heavy, I had to flip to the task manager pretty quickly to see it.

I am playing with ray tracing, and I’ve turned on the support for the planar reflections in the settings. However I have these 3 mirrors close to each other kind of back to back on walls in different rooms and I can get them too look so nice with the spherical reflections, but not all at once, as I just kill the GPU…

Thanks for the advice guys.

Sounds like If I reduce my editing settings. I should be able to I load this scene more. Then render off a sequence at high quality rather than flying around the scene melting my GPU.

With ray tracing off, I can get up to 9 captures in this scene. I found this post ::

https://forums.unrealengine.com/deve…-texture-sizes

It mentions this as a typical Newbie mistake. I’m using 8k and 4k textures. These 1080ti’s don’t allow unreal engine to do what I need it to do.
If I can get 6 captures in this scene with raytracing on, and 9 captures with it off. I wonder how many more captures a 2080ti will allow me to place.

Ah well, back to the start.

Not many. It depends on the memory of the card, not how new it is or how well it performs.

Yes I just checked that the 2080 Ti has the same memory as a 1080 Ti, its just faster.
I also noticed that when I am using ray tracing both GPU’s (SLI) are under load. ( I don’t know why)
Though I am told have read its not supported. If it was I would have 22gb of memory on those cards…

Anyhow I’m still sat with my problem with an overloaded scene. I am reluctantly reducing texture sizes now.
I think I need to arm a veteran with a stick, and pay him to come and beat me up over my work in Unreal…

Thanks for the heads up on the memory limitations. Seems I have no choice but to reduce texture quality.

Thanks

Edit:: Attached an image, look at all that memory I am not using… :confused:

GEFORCE RTX 3090 = 24GB Memory (Not out yet)
NVIDIA Quadro RTX 8000 = 48GB Memory (£6000+)

^^ 6000 are they out of their minds. … Back to reducing textures.

I’m not having a great time here. Its apparent that I am doing something wrong. I suspect I am overloading and ramping things up too high were I don’t need too.

I need to restart :frowning:

look, even when using 8k renders (movie production stuff for when some day a monitor/tv exists) your textures are usually 2048pixel max, some times 4k, but rarely.

Thats because generally items in the scene are displayed much smaller than the full texture resolution.

There is a visualization mode for lightmaps you can use to see what sizes are best.
https://docs.unrealengine.com/en-US/Engine/UI/LevelEditor/Viewports/ViewModes/index.html

Obviously it isn’t the same 1:1 for textures, but it gives you an idea of the size needed for decent shadows which are done with a texture.

Also, in the Academy, one of the base series on lighting/materials explains other ways to optimize ans reduce textures so they don’t compromise the memory load.

Another thing is that you should be re-using the same images as much as possible.
You can do a whole room with 1 single texture by slicing the items UVs up to fit in different areas if need be. then the items can all use the same material, reducing the load.
Not ideal to be sure.

the other obvious optimization is that every chair would be an instanced mesh. This applies to anything that can be repeated. Including walls.

Your pics look great. but I bet you that if you duplicate the project and change all the textures to 1080p you would barely notice a diffetence when running them in parallel…

MostHost LA. Thankyou very much for your time.

It took me a long time to get to this. You were correct, I think I had set at a very high resolution. It is now 128, and it was 2048. I have 14 captures in my scene now with multiple overlaps.

I have raytracing off, I have not tried to turn it on yet. Without raytracing::

A. I find my efforts bleached and gamey looking. Mirrors are not good.
B. I have a very high frame rate, and can work seamlessly in this mode.

Once the scenes are completed in this mode, I will turn the raytracing back on to see what happens.


I appreciate your guidance and will swiftly follow it up.

Thanks

Matt

A) reflection captures don’t really look right for mirrors.
you need planar reflections enabled and properly setup. You can look up almost any tutorial on it.
alternatively, just place a scenecapture2d behind the mirror, set it up to capture the scene, and use the render target it produces as the texture.
this is the most expensive way to do it, but it can look a lot better.

B) render cost for a simple scene (interior) should probably be around 12ms to 16ms at 2k res.
FPS won’t tell you the same info as millisecond cost does, since you are new to it you should get used to them. Use Stat Unit to get the info.

have fun.

Something happened last night, in Ray Tracing mode at 2 fps.

The captures are in a separate level to the lights.

The lights are in their own level with the lighting lighting scenario enabled.

At some point I was taking a screen shot and it was a bit bleached with light, for some reason I enabled the lighting scenario of he Captures.

The scene darkened and suddenly it was spectacularly realistic. Then I crashed. I’ve not been able to recreate this strange happening…

Once again, I seem to have surpassed any realism and I am back to grinding my head off the concrete wall beside me.

Before I turn on ray tracing again… Here is what I am looking at.


I’m so not happy with this, I’m just making more and more of a mess. Anyhow, lets see what happens when I enable raytracing on this scene… (I have no post active in these)

With Ray Tracing Still no Post and Capture Brightness 0.2

Next I will brighten up Captures and take these shots again.

The difference is slight, its all too dark. I refuse to increment the sky light as it will have me resetting the spectacular value on all the materials. So I’m going to Post Process this now.

So this is my light weight post process affect on these images …

One more process too go, this other one should bleach the scene somewhat…

Ok My last Effort here… (Ignoring my UV directional errors at the moment)


I do not know what looks real anymore…

Finally to compare all these efforts as the frame rate went from 80fps to 2fps during the process …

WHICH ONE IS THE BEST…

A). NO RAY TRACING
HighresScreenshot00003.jpg

B). RAY TRACING - CAPTURE BRIGHTNESS 0.2
HighresScreenshot00005.jpg

C). RAY TRACING - CAPTURE BRIGHTNESS 1.0
HighresScreenshot00008.jpg

D). RAY TRACING - CAPTURE BRIGHTNESS 1.0 + PostProcess A
HighresScreenshot00009.jpg

E). RAY TRACING - CAPTURE BRIGHTNESS 1.0 + PostProcess B
HighresScreenshot00011.jpg

Can anyone tell me which is the closest to realistic… ?

I think your walls need a little more roughness to avoid being shiny.
from the post above, B looks best, but the table is a little too shiny or reflective.
For realism you would want to make that shine into a pattern/cloud so that its not all uniform.

Pbr wise, for the woos beams I would use a roughness of .9 and a speculation of .1 or less. I think that’s mostly why the rest of the scene looks “fake” but you’d have to run some testing, which I know is hard given you don’t have a mater material going…