Anyone know what this lighting issue is?

When I made this geometry in Max, I made an Unwrap UVW modifier and changed the map channel to 2 and flattened the UV’s to create it’s lightmap, as followed by several online tutorials. Once I’d put the mesh in, I built the lighting and I have this issue on all of the doors in the same place. Can anyone help?

Thanks in advance!


Well what does your map look like? Are there more than the 3 (0,1,2)? Look into the rending pipeline if you have to.

I’ve taken the geometry of the door, added a ‘UVW’ modifier and set this to ‘Box’ and set all UVW values to 2048 - I believe in 3ds this is defaulted to map channel 1. Then, I added the ‘Unwrap UVW’ modifier and set this map channel to 2 on this. Then in the editor for unwrapping UV’s, I opened the map and then used the automated ‘Flatten Mapping’ function with all values set to their default in Max. Then once this had done, I exported it with Datasmith and then lighting was built. This was the outcome of JUST the doors. Some of the doors have more of the dots than others.

If I took the geometry and refined it into separate sections, i.e. door panel, door frame, handle etc and had these all with individual lightmaps and separate from one another, would that fix it at all? In theory, it would all for more detailed lightmaps if they were separate and didn’t need to try and squeeze everything into one?

Well to be honest your more experienced in this than me. If you still need a rubber duck, ill reply.


To be honest I don’t know what Datasmith does! :wink: I thought you don’t have to mess with the lightmaps it will do it for you…
I think it would be pointless to separate your door mesh (but the frame might be a good idea)! You should get a nice result like this!
Even 2048 for this mesh is way too high!
Have you tried it with a plain different material? Have you checked it in the lighting only view if it’s a lighting issue?
And as @GIGA-Money was asking: could you show us your lightmap for this mesh? /check it first which one is set!/

Hi @Makigirl. Datasmith’s been, so far, a game changer for us. It’s imported things in and kept things from our V-Ray files and converted everything so it’s compatible with UE. I’ve always imported things without making the lightmaps but there was always some errors somewhere. Mostly things overlapping and not lighting correctly. On 90% of the mesh I bring in that I make lightmaps for, it’s much better and looks so much cleaner. I’ve tried materials and nothing happens. The lightmaps are about 256 or 512. The lightmap in 3ds looks like this

Thank you!
Oh I didn’t know Datasmith is not so perfect! :wink: :smiley:
Well yeah doing your own lightmaps getting the best results! :slight_smile:
The lightmap looks nice the padding is VERY low for a 256 (or even a 512) so it’s cool (and I don’t even understand!) you get this result!! ? :S It is definitely the uv channel that Unreal uses for the lightmap?
…but that part of the mesh is nicely covered!
It’s very strange that you have those artifacts only on your doors! :S

Can I ask how do you light up the room? What/how many lights do you use?

I use a variation of point & spotlights. ALL lights are baked (static) for best results in lighting and performance. I have a total of 71 lights, 9 being the point lights and 62 spotlights (these have IES profiles on but are set to static to bake the IES in fully). I’m also using the Ultra Dynamic Sky (Ultra Dynamic Sky in Blueprints - UE Marketplace) to light the entire scene externally. - I’ll try separating the doors and make the panel its own piece and see if spacing on the lightmap that way fixes this issue. I’m still very confused as to what could be causing this but the lightmap.

I’d say it’s lighting setting… one or more of your lights causing it… IMO!!
Just a step before: have you tried clearing the swarm cache?
Do you have lights with tweaked settings such as indirect lighting intensity multiplied? Or very high intensity? …or with no shadow casting?
Would it be possible to reduce your lights to minimal (directional light and your sky) to see if the issue still exist? /just having ideas how I would trace down the problem…
And just to be clear these don’t appear anywhere else but these doors?

Weirdly yes, it’s only the door meshes that are affected. Some more than others but in the same space (at the top). I’ll do some tweaks with lights and the mesh and if I find a fix, I’ll post if back on here.

I’ve fixed it. I separated the door panel and made a separate lightmap for it. There were no artefacts at all. Perfect! Thanks for the suggestions and help.

No worries I’m glad it’s solved!! :smiley: