Anyone know how to get capsule shadows to work?

I’ve been trying out the 4.11 Preview versions. One feature I’ve been extremely excited about is capsule shadows, the approximation method for obtaining performance friendly super soft shadows.

However it’s been tough to figure out how to get started because there’s currently no documentation on them. In fact, looking up the search terms “capsule shadows” returns pretty much no relevant results on here or Google other than the news on the 4.11 features. So as far as I know, I’m the first person to ask about them.

So far, I’ve started up the basic third person template to check out some of the new features, and enabled ‘Capsule Direct Shadow’ and ‘Capsule Indirect Shadow’ under Lighting on the SkeletalMeshComponent of the ThirdPersonCharacter. I know they require some set-up, but the template mannequin character starts out with a capsule component. So I went into SK_Mannequin_PhysicsAsset to compare with what I saw when it was shown how it would be set up in the livestream. It seems to be all set up, and there’s nothing to change or enable in that menu to determine whether capsule shadows should be working. I then looked into the CapsuleShadowShaders.usf file in 4.11/Engine/Shaders to see if there’s anything I can do to enable them in there, but there’s nothing obvious (there might be something in there but I couldn’t find anything I understood to have that function).

I’m under no illusions that simply clicking on those enable buttons would be all it takes to get this working, especially in a simple template level, but I’m at a loss at figuring out what else I would need to do. It would be nice to have some documentation on these new features so that we can start testing them appropriately in preparation for the eventual full release, or at least a confirmation that this feature is not yet enabled on the preview versions. Of course I’m sure plenty of people out there know more than I do, so hopefully there’s a fairly simple thing I’m just too dumb to notice.

Hi Mr. Darko,

Setting up the Capsule Shadows is not too difficult. This is the simple steps you need to do so. The twitch stream you reference here is a good start as well.

Here are the steps you need to get the start of the implementation, obviously some tweaking required for better results:

  • Locate your Skeletal Mesh and right-click, then navigate to Create > Physics Asset.
  • Click OK in the next window (This is a part you would want to tweak for better results, but that’s not going to be covered here).
  • Name your new Physics asset something like PA_MyAsset_Shadows or whatever you need to know what it is.
  • Open the asset and use the twitch video to use some of Daniels suggestions for the best results. You don’t need a capsule for every bone, only enough to mark out where the major shapes are. Remember these are not used for collision for your character, only indirect shadows.
  • Open your Skeletal Mesh and in the panel on the left, type Shadow into the top. This will give you a category for Lighting where you can apply the “Shadow Physics Asset”.
  • Lastly, go back to your Skeletal Mesh in your BP for your character and look for the option “Capsule Indirect Shadow” and set it to true (checked).

To really get a sense of how it works use a default level and delete the the directional light and add a skylight to your scene. Now you have a simple scene that is indirectly lit and you can test your capsule shadows.

I hope this helps.


Thanks, applying the Shadow Physics Asset to the skeletal mesh is the step I was missing. It works great now!

Thanks for this nice summed up step-by-step Tim!

Thank you so much Tim! Best explanation I found so far.


I wrote some docs for this a little while back. These are still in the review process, but once they go up you’ll be able to learn about them in our official documentation as well. I’m glad this post helped you until we get those up. :slight_smile:

Would it be possible to make a movable point-light cast only capsule shadows instead of dynamic shadows on another movable skeletal mesh component?
If so it seems to not be by default if I simple select Capsule direct shadows.
Also turning off dynamic shadows on the skeletal mesh component will just make that component not cast shadows all together.
FYI am using the forward rendering.

In project settings under Engine - Rendering changing “Shadow Map Method” from “Virtual Shadow Maps (Beta)” to “Shadow Maps” solved it for me.