Download

All games that run on UE4 crash on startup

My Specs
OS:
Microsoft Software | Windows 10 Home 64 Bit

PSU: I’ve been told by several techs that my psu provides ample power to my system
EVGA SuperNOVA 650 G2, 80+ GOLD 650W, Fully Modular, EVGA ECO Mode, 7 Year Warranty, Includes FREE Power On Self Tester Power Supply 220-G2-0650-Y1

CPU:
Intel Core i7-8700K Desktop Processor 6 Cores up to 4.7GHz Turbo Unlocked LGA1151 300 Series 95W

MOBO:
GIGABYTE Z370 AORUS Gaming 7 (Intel LGA1151/ Z370/ ATX/ 3xM.2/ M.2 Thermal Guard / Front USB 3.1 /ESS Sabre DAC /RGB Fusion/ Fan Stop /SLI/ Motherboard)

GPU:
GIGABYTE GeForce GTX 1080 Ti Turbo 11GD, GV-N108TTURBO-11GD

RAM:
Corsair Vengeance LPX 16GB (2x8GB) DDR4 DRAM 3000MHz C15 Desktop Memory Kit - Black (CMK16GX4M2B3000C15)

SSD:
Samsung 850 EVO 250GB 2.5-Inch SATA III Internal SSD (MZ-75E250B/AM)

HDD:
Seagate 2TB BarraCuda SATA 6Gb/s 64MB Cache 3.5-Inch Internal Hard Drive (ST2000DM006)

So I own PUBG and Insurgency: Sandstorm. Both games crash on startup before making it to the main menu. I just downloaded fortnight to test and it does the same thing!

I’ve reinstalled windows 3 times recently and its fully up to date. Its installed on the SSD along with the games. All my drivers are up to date including the display driver which was updated very recently. I’ve even updated BIOS, chipset and tried rolling back display drivers to other versions.

Other games that I’ve recently played run fine, including CS:GO, Skyrim, GTA 5, CoH2, and others…

PUBG and Sandstorm used to run fine and I’m not exactly sure whats causing the problem

My computer is fresh from wipe and has no extra programs or anti-virus software, just firefox, steam, and the games

Any help or advise is greatly appreciated.

That’s really close for something with a 1080Ti, you could probably use a bigger power supply. It’s possible the power supply just isn’t doing a good job.

You could check also if running Firestrike (benchmark for systems, not made with UE) the same issue happens, that would at least give a hint if your power supply is to blame. I have used the following tool to check your system specs against and setting the max speed and voltage to processor (4.7GHz and 1.45V) it is still safe for a 650W PSU (it asks for a 615W as recommended). It is necessary to supply the correct values for the graphics card regarding the speed.

http://www.coolermaster.com/power-supply-calculator/

That samsung 850 EVO could easily be the problem here. I’ve also got a 850 PRO model and when i enable pagefile on that drive it will BSOD the system, especially when i run Unreal Engine. Just disable the pagefile on drive C and manually enable it on your HDD instead. Worth a try! (Since i disabled, i get no more BSODs, but SMART still showing degradation of the drive. Thanks samsung.)

PSU is loosing power over time, i think thermaltake was mentioned an average of 10-15% of loss per year, since the capacitors wears out. It’s age could be a fault if it’s an older model. 7 years of warranty won’t guarantee the 100% performance, you would likely end up getting out a 400-500W at tops after a while.

You’re lucky to got 2 RAM stick, take one out and test the game. Maybe one of them is faulty.

A tech had me put my computer through extreme benchmark testing using both Furmark and p95(I think those were the names) both running at the same time. It passed with flying colors

The latest version of Google Chrome here locks Unreal at start after I updated Chrome :slight_smile:

Now I have to close Chrome before I launch the Editor or game.

All parts were brand new as of March 2018.

I have reinstalled the games on both drives before and I’ve manually set Pagefile to D as you suggested. Sandstorm actually managed to make it to main menu, but crashed within 2 seconds.

I reset pagefile to automatic and tried removing 1 stick of RAM and then switched to the second, no effect what so ever.

A tech had me run extreme benchmark testing using both furmark and p95 at the same time. PC passed with flying colors and temps were great. It also passes heaven benchmark.

We are starting to lack where to mess with… check if Windows Defender is active and disable it. It might be active if there is no antivirus installed. Besides this, I would start changing things to try isolate the responsible in the following order:

Experiment with each one at time, don’t try too many mix of changes or it will be hard to tell which one is problematic. Make a list of at least two combinations. Let us know your findings.

PS: On a side note, check if there is no file with a crash dump generated. Fortnite will generate one and a screen will appear letting you to automatically send the report to Epic.

Well I just finished an 8 hour stress test using furmark and prime95(Not sure how much point there was in that). PC did fine, which would tell me my GPU is stable.

As for underclocking the GPU Ive turned on the Nvidia Debug Mode

https://www.evga.com/support/faq/afm…px?faqid=59594

and tested the game(still crashes), would you recommend going further than that? Beyond debug mode, I’ve never messed with those type of settings

I dont have another GPU and wont be able to get my hands on one anytime soon unless its one I can buy and then just return

Same with RAM sticks, this is my first and only build, I have nothing in the way of spare parts or PCs (other than a laptop)

I guess I can mess around underclocking gpu and cpu…

Oh and as far as windows defender and fire wall, I completely disabled both of them before I installed Steam and Sandstorm and kept them disabled for a while. Problem still persists…

Instead of doing those tests then, do this:

  • download the application at: CloudscapePerfTest.rar - Google Drive
  • unzip it and you will see an executable with same name, run it
  • choose the button Third Person at Dynamic Light Maps column
  • if the program succeed execution you will see a forest with a character which you are able to run, close it with Alt-F4
  • in the folder you found the executable there is another folder with the same name of the application, inside it there is a folder called Saved, and inside this folder another one calles Logs. Copy all those files and zip them and by last attach those as response to this thread.

If there is something wrong with your system we will catch that up.

It crashed instantly

Now we got an interesting info to start with. There is a video for you to follow and do exactly what is in it. Restart Windows after doing the changes it states, run the test or your games. Please, leave us with a feedback in case you succeeded fixing after doing what is in the video. Good Luck!!

So this causes the computer to hang instead of crashing to desktop. Tried PUBG, Sandstorm and the cloudscape test. They all freeze my PC so I have to do a hard reboot

Give me some more time to research this specific error. All that I have seen comments for now is that it is caused by a hardware combination of some sort. If the procedure changed behavior we are more close to a solution than before.

Ok, Thanks for your time

Here’s the new log files from cloudscape just in case…

So I found IGFX setting in BIOS and turned it on, plugged monitor into MOBO, and disabled 1080ti driver
Sandstorm runs, on lowest settings, at 20 fps, but it runs

To quickly tell about your issue, these are the errors Windows 10 are reporting to the game when it crashes:

  • first is reported DXGI_ERROR_DEVICE_REMOVED
  • end then DXGI_ERROR_DEVICE_HUNG which will crash

these errors happens because the graphics card stops responding for a certain period (milliseconds) and to try recover it, Windows 10 disconnects the hardware (this is why it is shown DXGI_ERROR_DEVICE_REMOVED ) and tries to reconnect it again, but the device still does not respond in a timely manner resulting in DXGI_ERROR_DEVICE_HUNG. If those errors are not sent to the application and it insists sending commands to the GPU will result in a BSOD (Blue Screen Of Death).

After looking for several posts in the Internet, several reports some root causes which once handled will bring the system to work properly:

  • not overclocking the CPU, leaving at stock clocks
  • not overclocking the RAM, leaving it at auto (not in OC profile either)
  • not overclocking the GPU, leaving it at stock
  • trying to use other PCIe power connectors from the Power Supply
  • make sure the 8 PIN connectors to the motherboard are well connected
  • trying to use more powerful Power Supply (at least Gold and 80 plus certification)
  • update graphics card BIOS (use a technician to do this or you might end with graphics card unusable)
  • update motherboard BIOS (use a technician to do this or you might end with motherboard unusable)

The issue exists for quite some time, and happens with lots of graphics software, not only games.

Make sure your Windows is set to High Performance:

  • Go to Windows Settings
  • Click on System
  • Click on Power & Sleep
  • at right you will see a link to click “Additional Power Settings”, click on it
  • at the Preferred Plan section, choose High Performance

Also, some graphical applications set the TDLr values to avoid the crash at least, you might see hiccups on the application if it is a game. Use the guide I wrote available here: instructionsTDLR.rtf - Google Drive

sure a hardware misconfiguration can cause it in different graphics software, but UE4 is known to have gpu HUNG crashes aside of hardware misconfigurations. they are simply caused by some obscure resource mismanagement from UE4 itself.
plenty of users have it:
to developers, ue 4.14 crashes! - Error: 0x887A0006 - 'HUNG' - Feedback for Unreal Engine team - Unreal Engine Forums / Unreal Engine is exiting due to D3D device being lost. (Error: 0x887A0006 - 'HUNG') - UE4 AnswerHub

at work we have a live UE4-based game in beta and a significant amount of our users experience this crash, and I also have it at home and at work (both on a GTX 970). I know I do not have any overclocked hardware and all my hardware is properly plugged and configured. I also only experience this sort of crash in UE4, and never in any other sort of game or graphics software (including different 3d modelling and animation software), not even in UE3 or UE3-based games.
telling people to check their hardware would be something to do were this a mere fluke from a few spare players, but the issue has a much bigger user scale that what would be reasonable to simply suspect misconfigured hardware - this issue is not an anecdotic happening from a handful of users.

also Epic has acknowledged and fixed a few of them Unreal Engine Issues and Bug Tracker (Search Results) - if your assumption were correct then Epic would have never been able to fix any of them in the past.
the issue exists on Epic’s side Unreal Engine Issues and Bug Tracker (UE-51650) and it affects Fortnite as well so it’s on Epic’s best interest to fix it :rolleyes:

@Chosker the is reported in several non-UE titles aswel, even Substance Painter has it happening from time to time, so those TDLr values at registry minimizes it or even workarounds it. I got 8 different hardware setups at office (mixed brands on gpu against cpu and mobo), none of them ever happen to show this, so it is that kind of issue that has several contributing factors, but I agree that UE is putting something added to the overall issue.

I do wish this issue to be fixed, I play games aswel lol, would be sad if this issue starts to show up here.