All but one mesh is black, why?

Hello, I’m currently working on a level in Unreal Engine 5 using only interior light. For some reason every time I bake my lights all my meshes but the floor are pure black. When I open up a blank level and bake the lighting it works perfectly fine using the same mesh and textures.

PostProcessVolume is off, and VolumetricLightmapDensity is over the entire level.

All Meshes are in the green of Lightmap Density.

Meshes: Lightmaps are applied and within the 0 to 1.

Lights tried: Point, Rect, and Spot.

Textures: 4k

World Settings:
Volumetric Lightmap, compress lightmap, Volumetric Lightmap Detail Cell Size: 200 Maximum Brick Memory: 30 Spherical Hamonic Smoothing: 0.02
Lightmass Settings: Static Light level scale: 1.0, Num Indirect Lighting Bounces: 3, Num Sky Light: 1, Indirect Lighting Quality: 1.0, Indirect Lighting Smoothness: 1.0.

I’ve also tried making the materials 2-sides and it didn’t help either.

It might have something to do with a nanite mesh with a non compatible material. The demo room wall turned black for me when I converted it to a nanite mesh. When I turned off 2-sided it displayed correctly. I think 2-sided, transparent and dynamic materials don’t work with nanite yet. I’ve also seen the material change to grey color and the default grid texture when incompatible with nanite. You mention it happening after baking lights, so it might have nothing to do with nanite, but I figured I mention it just in case.

Turns out it was due to a multiplier I had attached to the AO in the Master material I was using for almost all my material instances…

This is so true! I had my .fbx with nanite then I turn on my 2 sided and all turn black. when I turned it off the nanite its all works normal. Nanite still dont work with 2 side