Adjust Player's force on physics objects?

I’m just wondering if its possible to decrease (or increase) the amount of force the player applies to all physics objects?
I’ve got a few books (and other small objects) in my scene that are physics objects and at the default settings, if the player walks into them they go flying (like superman kicking a football). Rather than adjusting the mass of every object, I was wondering if there’s a way to simply control the amount of force the player exerts on these objects?

Anyone have an idea how to do this without adjusting the gravity of the scene?

I’ve had similar problems, I don’t think there’s currently any solution to this. You could try the add force/impulse node with negative values, but it might not do anything.

hmm thanks for the comment. I’m not adding force to a specific actor, its to every actor in the scene. I suppose I could try manually overriding the mass of the affected actors but I’d rather lower the force on the player as it seems like a better solution. For now I’ve just removed the player as a collision object. (IE custom collision and turned off pawn) but ideally I’d rather the player be able to kick things around.

Still haven’t found a solution to this. I’m wanting to scale back the “Bump strength” of the player character so I can control how far a physics object is pushed when you walk into it.

luckily i was searching about this today, what i’ve found is that you can change the “push” force in the character’s movement componnent, the default value is 750000 (what seems to be a very high value), i’ve set this value to 100, also you can override the book’s mass and “damping” to make it harder to push.

Hey veccher. Thanks for the answer but changing the values has absolutely no affect on my character. I dropped the push force down to 750 and nothing so I dropped it to 1 and then 0 and still no difference. My character punts things across the map like they weigh almost nothing. I even tried increasing the mass of the items to several thousand KG and though this did make a bit of a difference, it’s not much. It’s like you’re superman running around in the world and anything you touch weighs almost nothing regardless of the mass settings.

Did you ever figure this out? I’m having the same issue.

Hello Torquemod,
I think I may have an answer for you. In the character select the capsule (which is the root component) and and make collision type - spectator. Then, select your static mesh and make the collision type - physicsactor.

Now your capsule will not collide but the collision capsules around the physics asset of the character do which means you can kick things with each foot individually etc.

Hope this works for you as well as it has worked for me. Unreal is so good when you find the answer but such a wind up when you can’t.

cheers.
Podge.

I have added an answer which works for me. See below. Good luck.

Hey cool. I’ll try setting this up in the next few days and if it works for me, I’ll be sure to select your answer as the correct one. Just got back from holidays though so It’ll be a while before I work on the project again.

So 3 years later and there’s still no viable way that I’ve found to scale the player’s push force. Doesn’t matter how much an actor’s mass is, the player throws it around like it’s a piece of foam. This is really stupid. I wish there was a way to disable the player’s push influence entirely but like I said earlier, the Force amounts in the character movement don’t change anything and Podgyhodgy’s suggestion didn’t do anything either.

I have just done it again from scratch.

  1. new project - third person with starter content.
  2. add blueprint actor called ‘kickable_thing’. To this, Add a cube component (scale 0.2 in all dimensions for sensible size) and a collision box component as child of the cube component (size this also). Tick simulate physics for cube mesh and give it a mass of 1 Kg. Under collision set Collision presets to PhysicsActor. For the collision box the simulate physics is not ticked, the mass is 0.3kg and the Collision presets is PhysicsActor.
  3. In the Thirdpersoncharacter select the capsulecomponent and make it Spectator.
  4. Select the mesh(inherited) of the thirdpersoncharacter and make its collision preset PhysicsActor.
  5. Add cube to scene. Walk up to it slowly.

Yes or no?

Oh, yes this does work thank you. Is there a reason why you set the collision preset to Physics actor on both the character and the kickable object? The reason I ask is I wanted my character to be a ragdoll so I can transition into ragdoll on death and I wasn’t sure if they both had to share the same collision preset or what the reasoning was.

I am adding this answer because, as has been confirmed by Torquemod, it does work. This is a more detailed than my previous answer that got downvoted but it is the same thing really. Try it and see.

I have just done it again from scratch.

  1. new project - third person with starter content.
  2. add blueprint actor called ‘kickable_thing’. To this, Add a cube component (scale 0.2 in all dimensions for sensible size) and a collision box component as child of the cube component (size this also). Tick simulate physics for cube mesh and give it a mass of 1 Kg. Under collision set Collision presets to PhysicsActor. For the collision box the simulate physics is not ticked, the mass is 0.3kg and the Collision presets is PhysicsActor.
  3. In the Thirdpersoncharacter select the capsulecomponent and make it Spectator.
  4. Select the mesh(inherited) of the thirdpersoncharacter and make its collision preset PhysicsActor.
  5. Add cube to scene. Walk up to it slowly.

Don’t know too much about characters in unreal. I am dedicated to producing a working realistic physics driven helicopter. It does take years doesn’t it? I worked this out by bloody minded trial and error driven by the belief that it simply must be possible. Can’t point you at any documentation.
I have seen out of the corner of my eye talk about blending physics and animations which might be worth a look or, if you enable physics on the character then he will collapse in a heap - enabling physics can be done in bp.
Anyway, I have reposted my answer to you as an answer to the question so I hope you will give it an uptick. Not that I care but it might help guide someone else to the answer.

I know this is quite old, but this totally worked for me. Make sure you recompile and save everything.

Just an update to anyone that has issues like this, where physics assets seem to be feather weight upon contact and often fly off into the distance. This is generally caused by conflicting collision settings, without seeing your code/blueprints directly it may be difficult for anyone to solve individual issues. The best suggestion in this regard would be to go over all your collision settings for the assets you’re interacting with to ensure they are set correctly, including your characters’ settings.

Does anyone know how to solve this?

Depends on what you mean. The character movement component offers some control over this: