Activating forward rendering killed my reflections

I am working in 4.15 and just enabled forward shading last night which helped in some ways, but it has made it so none of my emissive materials reflect on the surface next to them like they used to. I tried adding in a reflection capture volume which I did not need before and they are still not showing up. Oddly only one thing out 10 different emissive items reflects now, a point light.

Additionally it is causing some visual glitching and noise to appear in some laser beam type material/particle emitter I have when the material turns on and off.

Any ideas what has happened?

SSR techniques, like Screen Space Reflections, are not yet supported.

Thanks Tim, that explains it. Is there any workaround available currently for reflections or should I just hold off until a later update?

With the Forward Renderer highquality reflections from Reflection Captures and Planar Reflections require you to opt-in to them in the Material. This is where some of the performance savings come into play for the Forward renderer.

So if you use Planar Reflections (Planar Reflections in Unreal Engine | Unreal Engine 5.1 Documentation) you can enable this in the Project Settings > Rendering > Support Global Clip Plane and then in your material for the surface that you want to reflect you can enable “Planar Reflections” from the Material Details panel.

These come at their own cost, so you’ll want to make sure that you use them wisely and test before committing fully. If you want the screen space techniques (ssr, ssao, contact shadows) you’ll have to wait until these are implemented.

Just wanted to say thanks again for detailed answer. It’s working perfectly now, looks even better than before. Thanks for your time.

I’ve now spent a couple of days looking for a way to use a planar reflection and forward shading at the same time, and it looks like that one checkbox in the material finally did the trick. Thanks a lot!