Download

"Action RPG" template alpha objects in front of nanite objects render underneath

When using “Action RPG” template any objects that are not nanite and include some kind of alpha will not render properly in front of nanite objects, in the screenshot it shows a nanite rock with the bizarre layering and a normal non-nanite rock performing correctly.

EDIT: I also tried mimicking the project settings of the third person template in which nanite worked correctly but none of the options seemed to change anything, nor does anything seem related to the issue. I also turned off anything that would cause a visual issue, including placing brand new quixel vegetation in front of a nanite quixel rock in a brand new level, so assuming it’s a problem with the C++ code or some obscure project setting.

UPDATE: I copied over the entirety of the config from the “third person” template and it seemed to solve the issue! Assumingly it’s some outdated setting stuck in the 4.26 Action RPG template configs that can be easily replaced.

More updates: I went back to the old config file of the Action RPG but this time just deleted the render settings in “DefaultEngine.ini” since using a different config (or outright deleting it like I also tried) seemed to cause compile issues, narrowing it down to one of those settings, might go through and figure out which setting causes the issues if I have time.