Download

Action RPG Inventory System

to get player inventory array, get player controller, cast to inventory player controller, get inventory manager, get player inventory, get inventory. You can make a function in the interface to make it easier in future. Creation/refresh of UI is all done in Iventory manager, which has access to Inventory component which is where your inventory array is.

Hope that helps

Cool thanks, looks like most of the logic or fucntion is already in the inventory manager. Found these CheckInventoryForItemAmount, TryToAddItemToInventory, TryToRemoveItemFromInventory. Probably make a datatable then with arrays of required items, isunlocked?, amount,etc… A Crafting Widget, then leverage the Inventory Manager Functions, Events. Basically i think the craft system would just be using items, remove them, then spawn an item like how loot is spawned in a container by placing it back into the player’s inventory.

I am trying to migrate the inventory system but after the youtube clip I found about that, the inventory, equipment and container panels aren’t visible and between 1000 and 4000 errors occure after play… I am using 4.25.3 and wonder if there is a version conflict that requires more changes in the blueprints.

Few questions, are you using your own character and controller or the ones from the ARPGIS?

Did you migrate from Inv system to your project?

Check that you moved the whole ‘initialize character’ ( ithink that is what it is called,) from the rpg controller begin play to yours. looks like the hud reference is not set correctly

I use the third person character from a new project as I am testing and don’t want to ruin my actual character and made an own controller (do you need a controller? I not seen anyone in any tutorials using one so far). I did migrate from Inventory system to a new project as per clip on youtube about migrating. I will check that and see if I may have forgotten something.

Hotbar_C failed to route PostInitProperties

Anyone else getting this on launch of game on Android? 4.25.3

Update: I unhooked the construction node on the hotbar ui widget. The game will now load and all other inventory functions are working correctly. I just need to figure out how to fix the hotbar issue.

I fixed the issue with the white item slots. Now I can only drag items from loot container into the inventory/equipment but not into hotbar. Nothing can be dragged into the hotbar and nothing dragged into inventory/equipment can be dragged out. Just using the box asset. Any idea why that happens? Nothing else changed apart from the white item fix.

I got the hot bar working by duplicating the inventory. I duplicated all functions and custom events(renamed them with hotbar instead of inventory), duplicated all local variables and created new variables if needed for every duplicated function.(renamed them with hotbar instead of inventory). Replaced all the functions with the correct new hotbar functions that were duplicated from the inventory functions. After everything is said and done, I can now set the size of my hot bar, add and delete hotbar slots. You will need to write your own blueprint code from here to drag items from one inventory to the hotbar inventory, how you want items to work when you drag out of hotbar inventory and how items are used in your hotbar inventory. In my case, I want to write the blueprints to work how the inventory system originally worked as far as hotbar goes. I am now able to deploy to Android and avoid the hotbar crash in 4.25.3

@mattxordev1 @MauganKhaine Do you want me to post my hotbar? It is basically a copy of the skillbar I think.

I am ok. It was actually nice learning how to duplicate the player inventory. Now slots can be added or removed and items are stored in separate inventory arrays per type of storage(Hotbar, storage bank , player inventory ect…). It opens the door for other types of storage.

Okay, so I use a single inventory, except for the stash which operates partially on own functions. Providing an entire extra inventory for the hotbar feels not very efficient.

If you don’t mind. All I want is that you can drag items like potions and food and such into the hotbar and use the numbers keys to use the corresponding slot. As for now, I can’t drag Items from and to the inventory nor equipment panel but can drag from the container into the inventory and equipment panel. I know it was possible before I fixed that issue with the inventory slots being all white so you couldn’t see the icons. After I fixed that according to this forum, dragging and right clicking in the equipment panel to unequip stopped working. And I fixed my issue that the inventory stopped being displayed. Turned out it was the equipment panel which I extended to 20 slots that caused the problem.

The way this inventory work is, the equipment slots are counted first, thus when you increase the size you have to adjust also the equipment slots, for example inside the HUD Inventory Layout / EventGraph. Will post my hotbar later.

Hotbar and Hotbar Slot example Blueprints, and the InventoryLayout, in case you adjust the amount there.

The hotbars are basically copies of the Skillbar and Skillbar Slot. Let me know if you have any questions, or want to see a specific blueprint.

Hello Everyone, I finally got around to working on setting up this system into my game and fortunately got it all working with a bit of troubleshooting. I added in a new item which pops in properly, connects to the socket and has a proper icon for it. My only issue now is that my item is rotated about 70 degrees in the wrong angle (and needs to be moved about 10 on the z scale so the hand grabs the handle at the proper location). I had tried adjusting the skeletal mesh and that particular item BP itself but neither seem to reflect the changes when equipped within the game.

Is there any way I can make this rotation without needing a third party modelling tool by any chance? (I have no idea where even to start with things like that)

Any help would be greatly appreciated.

Thanks,
Scyclone

@Scyclone not 100% sure what your problem could be as there are no screenshots, but i’m guessing your item is not rotated and positioned correctly with it’s ‘world origin’ at 0,0,0 (it’s transforms all at zero in other words).

  1. A quick UE4 hack that may work for you is to drag the item into a level, any level will do.
  2. Set the location to 0, 0, 0 in the Transform section.
  3. Make sure the item is rotated correctly, vertical for melee and horizontal for guns.
  4. Where ever the pivot point is will be where your character ends up holding the item, so adjust as you see fit.
  5. Right click on the item and select Merge Actor
  6. Under Mesh Settings make sure the box ‘Pivot Point at Zero’ is ticked.

Your new static mesh will now have the pivot point set to zero and you should be good to go. This will only work if your items pivot point is at 0, 0, 0 on the level in step 1 when you place it.

Hope that helps.

Heya @Mahluus7 , you make a fair point - a picture is worth a thousand words :slight_smile:

Essentially, the axe is attaching to the socket - it just looks wierd in terms of rotations and such. I mean that could lead to a very painful circumcision I’d imagine :P.

Would the information above apply to that?

As an unrelated note, I’ve been working with adding in new stats and such to my items. And I have had ‘some’ success thus far.

I added in Damage (Objects) to items that are designed for harvesting (Axe/Pickaxe/etc), as well as Constitution. I updated the itemlist, updated all relevant structures that I can think of and from a mechanical standpoint. It does apply the statistics to the item because it is populating into my equipment screen. For the screenshot example, I have put in 2 constitution for the bladed shoulder piece.

I have narrowed down the issue in that it doesn’t seem to populate “ItemToolTipInfo” with the data on my item’s constitution bonus. I did a test on the visibility (and basically set it always visible) and it returned a blank line [further showing me that the ‘BreakToolTipInfo’ for Constitution is returning me no value]. Is there some extra step I missed somewhere or something I can do to correct this issue?

Shoot… I came here for the exact same issue. I added a Hunger value, but it keeps returning 0. If I find a solution, I will post here and send you a message.

Okay so I found out where else you needed to hook up your new entries. You need to open the Inventory_Slot, Container_Slot, and Hotbar_Slot and open the Get_ToolTip_Widget function. You should see there where you need to hook things up. Hope that helps.