Able Ability System Info and Support Thread

I probably should have been more clearer in my instructions, so I’ll lay things out how the new drop down system works:

The new system no longer uses a wizard to help pick a Preview / Target actor. Instead, it uses a Whitelist of classes that are defined in your Able Editor Settings to decide which Assets should appear in the new dropdowns on the Toolbar.

So, if the characters in your game inherit from Pawn, or Character - you can add those to your Able Editor Settings “Allowed Classes” under Preview Target - and only assets that inherit from those classes will be shown. This helps filter out other actors like Static Actors which caused a HUGE delay when opening up the Content Browser to select the assets. If you don’t know what your Character’s inherit from (which seems unlikely…) you can just add Actor and that will pick up just about everything (while still filtering out some unwanted content).

EDIT: Also I found the shipping error and missing assets. No idea how that made it through the pipeline. Fix incoming immediately.

Hi Matt, I am testing out this new version now.
Yes the colour of the timeline is white like above.
I have tried adding target character to class but it does not add character to scene for some reason.
Also Jump to and Move to does not work at all. I know you said you will be working on it but thats just confirming.

Are you sure your Character inherits from ACharacter? As I said, you can just toss in Actor or what not and it should pull everything.

Jump/Move To will not work in the Editor unless you set it to use physics and have a valid target setup. I’m a hair’s breadth from just removing those. I doubt I can get them to work generically for projects (which is why I was so hesitant to add them in the first place), but we’ll see.

The white bars and such will be fixed soon (about to submit the update).

Alright, update submitted and hopefully it hits later today. Again, sorry for the issues.

I know I’m super frustrated with this update (probably should have just taken the extra month of testing) so I can only imagine the frustration on the user end, but it does have some very good fixes and features so I ask for your patience while we hammer these things out.

Thanks. Btw tried updating it all to 4.22… Didnt work and lost most of it >< cry. Still got my data tables and anims luckily so redoing it all now and make it tidier. Should of backed up.
Gonna do bpi and ac more tidy now

Use Perforce. Takes two seconds to setup (you can easily find tutorials all over the web) and will save you lots of heartache.

Hi Matt :slight_smile:

I got Perforce now thanks.
Trying to simulate physics and all to get this to work.
Its not doing anything as of yet but got any pointers into where to look and research?
Thanks Jesse

Not yet. That’s the problem with Move To / Jump To is it requires that your character is setup in a particular way (has a root shape component or uses the Character Movement Component). Honestly, you have to debug and step through them to see where things are going wrong. Again, that’s the problem with Character Movement in general - it’s VERY case specific.

I’m going to look into them some more now that the update is out, but for the moment I’d just avoid them entirely.

I am trying to create a binding for the branch ability. when I hit the plus button to create a new binding, it creates a new function “OnGetDyanamicProperty_Ability”. it doesnt seem to set the next branch ability at all. this doesnt work for some reason.
edit: I realize after reading the rest of the posts i should wait for the update to hit first.

Hey…I want to buy you plugin but before I do this I want to get sure that this will solve my problem…

My problem:
When I try to do an SPRINTING using Left Shift or other key > Client call an RPC to the server > Change the MaxWalk Speed and active p.NetShowCorrections 1…I see a lot of errors and movement corrections…

With your plugin I can do a sprinting in networking game like without need to use C++???
What the diferrence of your plugin and the Gameplay Ability System from UE4???

Great! Big thanks man ;D

Can you elaborate? If you are using a binding on the Branch Ability, the Ability you return from OnGetDynamicProperty_Ability will be the one that should be branched to.

Able was written as an alternative to GAS (because GAS at the time had almost no documentation and the editor wasn’t meeting my needs). As for the rest of your question,it’s hard to say. You can definitely create a Custom Task that simply modifies the character’s max speed on the server/client (no RPC necessary) - but Able has no effect on your character movement code and how it handles corrections.


I’m getting a fairly consistent issue when using this system. After I create a blueprint ability based on AbleAbility, save and quit. My editor crashes without fail on each subsequent launch. I can only resolve the issue if I go into the file system, and delete the Able Ability I created. Here is the log:

UE4Editor_UnrealEd!FBlueprintEditorUtils::IsDataOnlyBlueprint() [d:\build++ue4\sync\engine\source\editor\unrealed\private\kismet2\blueprinteditorutils.cpp:3114]
UE4Editor_Kismet!FBlueprintCompilationManagerImpl::FlushCompilationQueueImpl() [d:\build++ue4\sync\engine\source\editor\kismet\private\blueprintcompilationmanager.cpp:485]
UE4Editor_Kismet!FBlueprintCompilationManager::FlushCompilationQueue() [d:\build++ue4\sync\engine\source\editor\kismet\private\blueprintcompilationmanager.cpp:2554]
UE4Editor_Engine!UBlueprintGeneratedClass::ConditionalRecompileClass() [d:\build++ue4\sync\engine\source\runtime\engine\private\blueprintgeneratedclass.cpp:234]

Maybe related, I cannot clear the Preview Asset after I have selected one. No matter what I do it stays in the view. Any way I can work around these things?


yes that is correct. but the return node does not work at all. In the graph the branch node is null, and will not play any animation unless i set an ability to branch to directly. the binding, even if set directly in the return node does not work. The timeline only reads the static value it will not read any return node. - Bound Ability Branch Blueprint - Timeline

Thanks for the additional details, I’ll dig into that.

Is there anything created in the Ability? Or is it just blank? If possible, can you make an Ability that shows this behavior and upload it here?

For the Preview Asset, you should just be able to hit the Reset Preview Asset button. You can also directly set it via the Ability Editor Settings (and then either re-launch the Ability Editor, or hit the Reset Preview Asset button).

Thank you for the reply.

For the ability, I have reproduced this both with a blank ability and one with a couple of tasks in it. I uploaded one of them for you. My workaround right now is to move the ability files outside of the project, launch the editor, and paste them back in. Although this works for now, I have to re-link them in my character blueprint variables.

For the preview asset, I have a sneaking suspicion that this is what is causing the above to happen with the crash. I have tried clearing it in the following ways:
1- Reset Preview button.
2- Selecting the dropdown where the preview asset is, and selecting “None”. I
3- Going to editor settings and removing the list of allowed preview assets, then repeating any of 1 or 2.

I have also tried reinstalling the plugin, deleting the abilities, and remaking them. In this instance, what happened was the editor loaded and asked me to select a type as a preview asset, but after selecting a completely different asset, the original asset that was stuck in the preview window was still there.

Let me know if you need more info.


Edit: Forgot to mention that the preview asset I have on screen cannot be interacted with. ie: It does not move when animation task is set, I can’t select it to move it around, etc. It’s just visible.

Thanks, I’ve grabbed that file and I’m going to start investigating. What Engine version btw?

This is on UE4.22

Gotcha. I’ll have access to 4.22 tonight, so I’ll check then.

I ran things real quick on 4.20 and things seem to work fine with the Preview Asset. Refresh works, etc.

Does the Actor you are trying to use actually have a shape component on them (capsule, sphere, etc)? And once you click on an entity, you need to use W/R/T to change to Translation, Rotation, Scale. I’ll make it default to translation upon picking an actor to make that a bit more transparent.