A ton of old posts have been erased, what happened?

An update has gone through that should help with some of the re-mapping to the forum links from external pages (searching on Google and clicking a link), but I see it’s still not working on Rama’s :frowning:

I’ve reported your case and please know we’re digging in!


I have a big (and important to me) forum topic that I can’t find anywhere anymore:


1 Like

I also have one not working:

Yep. Tried to use search and found nothing.

I am getting the same message for Uefy thread: Uefy 2.0 (Pro Edition) make Blender's rigify rigs compatible with UE4, also has a FREE version - Community Content, Tools and Tutorials - Unreal Engine Forums

Perhaps it is because on new versions releases I have changed the topic title before. In the previous forums all of the topic title versions continued to work regardless of changes.

However for now it seems none of the urls are working. Even the latest one from the old forum.

Yes. But the topic you mentioned at least can be found by Search:

The one with USQlite can’t be even found by Search.

Please, we already suffer A LOT when links to the wiki got broken in the wiki update, don’t leave this broken and do something to successfully redirect to the new URL standard.

It’s a stab in the back to us the devs to lose all the content that is available on guides, tutorials and forums discussions!


Hey all, thanks for reporting the missing topics—we’re working with Discourse to get these restored as soon as we can.

Can you share the info if you’re using custom build of Discourse?
Can/will you customize it?

Links from outside sites still get the error Oops that page doesn’t exist or is private:

For example, my topic used to be at this URL:


Now I can find it through my Profile Activity or by searching at this URL:


Or the shorter form with just the topic ID:


I’m guessing the ship has sailed on keeping old post IDs in the new system… but it should be possible to remap incoming requests to the old forum-style URLs:


To the new post ID:


Of course this would require using a data table generated by the conversion to Discourse, mapping all the old post IDs to the new ones…

Google will update to the new URLs in due time (or may have already), but every AnswerHub post, Twitter post, YouTube description, personal blog, etc out there linking to the old URLs are now dead…

Please help! :pray:

1 Like

Hey all - we’ve run a script to update these links and restore the missing topics/posts. The ones you’ve shared here all appear to be working for me. Would you mind confirming that they are for you as well?

Topics are back, thanks a lot. But there’s like 90% of posts are gone lol

The script is still in progress so maybe it hasn’t snagged all of them yet. The links were showing promise, so I got excited :wink:

I’ll circle back once it’s completely finished.

1 Like

They should all be sorted now - do your posts look like they’ve returned? If not, minding sending over links to the topics?

No, there’s just a few posts there.
I’m going to wait, maybe they show up later ?!

[PLUGIN] USQLite - Unreal Engine / Marketplace - Unreal Engine Forums

1 Like

Most of the ones I’d previously tested now seem to be working, including links to individual posts.

However, I’ve found some links using the showthread.php?<postID> format linking to individual posts within those threads, that just go to the top of the thread. For example:


or the shorter version:


Just goes to the first post – when it used to link to this post further down in the thread:


On the bright side, I’ve tried some other direct links to posts using the more recent verbose URL style, which seem to redirect correctly. For example, this old sub-post link:


Correctly redirects to this new Discourse sub-post URL:


Particularly in longer threads like that, linking directly to a post instead of the top of the thread is crucial.

@Amanda.Schade Thanks for all your hard work in getting this sorted out!

1 Like

That’s great!

Yes, as you described, the old format (showthread.php?) URLs that point to a specific post are just pointing to the topic right now. Apparently those IDs are a little more difficult to map out and will take longer to get sorted.

Today’s update hopefully makes the general experience more friendly, and resolves a majority of the link issues while we manage the others.


1 Like

Understood – teething pains are to be expected. Overall IMHO the Discourse UX is really nice compared to the old system (and I’m much more accustomed to old school style forums)… we’ll adapt in due time :wink:

1 Like

Hi, this topic for my marketplace plugin used to have 10 pages or so of posts on the old forum: Auto Settings - Game options and input binding toolkit

Now it just has one that looks like it’s from a spam bot.

Overall I feel the new system is nicer but hope these old posts can be restored.

lol some 40ish pages of posts in USQLite plug-in topic are really gone.

There was a lot of technical info in there and successful user’s experiments that are now all gone.