5.1 DX12 RHIT Lag: Single Digit FPS


Getting a strange issue that started out of nowhere. I’ve got a 13900K/3080ti/128gb RAM, machine runs stable rendering/gaming.

I’m working on a scene and the FPS has degraded to single digits. I’ve started looking for a reason and so far it looks like Nanite meshes cause this degraded performance for me.


When using the GPU profiler, getting ~25ms on the Shadow Depth pass. I have a fresh install of windows 11, nvidia studio drivers, UE is not using even half of my VRAM, no thermal throttling, PC is running at 45degrees.

The issue let up for JUST a bit when I deleted intermediate/saved files in my project, but I haven’t been able to replicate that.

Was really looking forward to cranking out an environment over the holiday break :*(

Thanks for reading!

Hey there @ruski! Welcome to the community! So this can happen sometimes with really heavy lightmaps or massive overdraw. Thread with a somewhat similar issue (but for mobile which always much harder to balance).

How does your insight profiling look?

Tried that but it didn’t work. I was running the entire scene just fine, but after I changed the streaming pool size, something just broke and my FPS has tanked. Not sure what else I can try but wait until a new version.

I’m running with cinematic scalability in a different scene and FPS is great, everythings fine. Using DX12, nanite, lumen, literally the same settings.

Make sure you didn’t somehow cap the fps.

The way the engine does it is murk up the rendering pipeline with a delay, so fps limits can look almost undistinguishible from any redering issues.

If you adjusted the streaming pool via command line, there’s a very real possibility you misstyped the value to use. As in KB instead of MB or similar, so maybe check that 3 times too.

All else fails, start a new peoject, slowly migrate assets until it breaks agai so you know what caused it…

It’s like Unreal has stopped using my graphics card properly. These are insane profile values, for a scene that used to work just fine. I ran the better gpu profiler and it was similar.

I’ve deleted all my config files which should reset everything, it worked once for about 15 seconds and then it went back to being slow.

Guess the last thing I should try is migrating assets slowly. Maybe I’m missing something SUPER obvious, which has definitely happened before, but I think I’ve just found a nice rare bug lol.

Asset wise, before you floor it to 1 fps you would get assets just not being rendered at all by havi g exceeded the tris limit - one would hope anyway…

Something must definitely be the matter with an engine setting in my opinion.
Maybe multiple editor tabs being open, or many actors that include catpure/render(s)…

It was working after the shader cache was deleted for a bit? Interesting, could just be a caching issue, I agree with MH, there’s likely a specific asset or multiple assets causing that.

Same issue with a big no on RHIT, t.MaxFPS 3000 fix it for me, never see RHIT over 0,8ms anymore.

Update: Nope, it comes back after 10min or so…

1 Like

Do you happen to have a lot of small objects in the map?

I have exactly the same problem, it came out of nowhere. I was working on my project and suddenly the fps was at 30. I started trying to solve the problem because I thought that it was my intervention that broke everything, in the end I didn’t fix anything. I handed over the PC for repair for verification, everything is fine with it, no problems. The next day I checked the project, everything is the same,
but what’s worse, all my projects lost fps and all of them had an RHIT score that went off scale. I created a new, stable project and everything is the same in it. Reinstalled 5.1.1 created another new project, and everything is the same.

Anyone found any solution for this?
struggling with a similar issue at the moment.