[5.1.0] Is there a workaround to Render Target no longer removing the background?

I am currently unable to render my character properly on the UI anymore. I have tried just about everything but it seems like setting the material to masked / User Interface and using a one minus x node from alpha to opacity mask breaks the render target where it no longer shows. Any other variation of the settings will either show a black box behind the character or not show the character at all.

I do plan to submit a bug report but I was wondering if anyone had a work around. I have tried using the “if” node to remove the black background from the character as well as a variety of combinations of translucency and masked with different camera capture source settings and composite mode settings.

Here are my render target texture settings:

Here are the in world scene capture camera settings:

Here are the material settings:

Here are my material left hand settings:

Let me know if you have any thoughts on this issue. I have built with source and tried with the prebuilt engine as well in fresh projects and my own.

same issue

IF - and that’s a big if - RTs are broken, then make 2 RTs.
Set one to have a green background - or any color that’s definitely not on the character.
PRIMARY colors, so that you can pull the white/black off the single channel.

Then you subtract the Green (or other) channel from the full render target - or use it as the opacity mask.

Now, my thinking here is that the Alpha node is already the way it ought to be to plug into the opacity mask as is.
Afterall, A stands for Alpha. Why did the opacity mask need to be inverted in the first place for the UIMat node?
You can check on this by just previewing the 1-x node.

I’m having the same problem. It was working fine in 5.0.3 but not working now(5.1). either black background or nothing

I ended up having to revert to 5.0.3 (and reset my entire pc due to xcode’s upgrade and it not working with 5.0.3 source) because of the issue. I’m not sure why it its broken but there was no fix that I was able to find.

Same issue here i have a nightvision overlay Post-Process material with Render Target and it is all black. Works fine in 5.0.3 or previous but not in 5.1.0. If anyone gets a solution please share

What is wrong with temporarily subtracting one RT from another to replicate the behaviour - if - you really don’t want to wait on a fix (which really no one can blame you for? Though perhaps consider building from source to fix it instead?)

1 Like

Nice idea but i think my issue here was a little different my mistake! i posted the solution (not my idea) to this link!. Thanks

Going by that, you probably had a slightly different issue.

At least from reading, it seems that the RT isn’t capturing alpha at all, not that the material isn’t writing it. Which yes, the flag would fix :wink:

Hi @MostHost_LA Been looking for the code to fix in my source build, do you happen to have a link for this, I’ve scoured the forums but cannot find.

That’s funny, I recall someone posting about it here as well, yet the post has vanished?

Either way, it wasn’t me, and I don’t have anything nor have I had time to follow up by reading the github commit notes this far.
I would suggest getting the latest nightly to try it out - then if it works, manually patch the good release with the specific fix (move over the header and c++ file) for the scene captures.

1 Like

No worries at all - Thanks!