4.8 Promoted Build, Unable to Hot Reload

I haven’t been able to use hot reload in the promoted build, not exactly sure why that is so I can’t provide much information about what I may be doing wrong, but here is the output log that I get, note the line about the file not being found, unsure of what is causing the disconnect between the Unreal editor and Visual studio.

Recompiling TurnBasedStrategy...
Building UnrealBuildTool...
Building UnrealBuildTool in E:/Engine Versions/UnrealEngine-promoted/...
Running: C:\Windows\system32\cmd.exe /c "E:\Engine Versions\UnrealEngine-promoted\Engine\Intermediate\Build\UnrealBuildTool\BuildUBT.bat"
Launching UnrealBuildTool... [E:/Engine Versions/UnrealEngine-promoted/Engine/Binaries/DotNET/UnrealBuildTool.exe TurnBasedStrategy -ModuleWithSuffix TurnBasedStrategy 5483 Win64 Debug -editorrecompile -canskiplink "E:/Unreal Projects/TurnBasedStrategy/TurnBasedStrategy.uproject" ]
Warning: Starting HotReload took 12.5s.
CompilerResultsLog: New page: Compilation - Feb 5, 2015, 1:49:11 PM
CompilerResultsLog: Info Compiling game modules for hot reload
CompilerResultsLog: Info Target is up to date.
LogMainFrame: MainFrame: Module compiling took 13.414 seconds
LogModuleManager:Warning: ModuleManager: Unable to load module 'TurnBasedStrategy' because the file 'E:/Unreal Projects/TurnBasedStrategy/Binaries/Win64/UE4Editor-TurnBasedStrategy-5483-Win64-Debug.dll' was not found.
Warning: HotReload failed, reload failed /Script/TurnBasedStrategy.
LogContentBrowser: Native class hierarchy populated in 0.0322 seconds. Added 1799 classes and 281 folders.

Is this an uncommon error, a common error? Seems odd that the system working to create the new compiled version can’t find the version it just compiled.

That’s engine generated, I’ll try removing the list of current files in the directory its looking in and see if its just a duplication issue.

Does the DLL it is looking for, actually exist where it is located?

Is that 5483 number something that you specified somewhere or engine generate that?

I work also on the current Promoted Build and with my project everything works fine.

I have one question, is your intention to work in the Debug Build correct? Or did you Build your Editor with Development and now somehow things in VS are in Debug Build?


I personally don’t know if that is the case. I will give it a try since I never work in Debug Editor. In DebugGame Editor works fine. Need about 30 mins until it compiles my Debug Editor and than I will give a short feedback if Hot Reload worked allright.

Alright, so when I try to recompile using the editor, which is where I get the failed hot-reload message its looking for a file that doesn’t get created, not sure if that means the compiler isn’t getting connected to, or what-not, and when I compile in VS it is creating a .dll in the file link:

Vs Library File:
E:\Unreal Projects\TurnBasedStrategy\Intermediate\Build\Win64

Vs Object File:
E:\Unreal Projects\TurnBasedStrategy\Intermediate\Build\Win64

That is different from the file location that the in-editor compiler is looking at:

E:/Unreal Projects/TurnBasedStrategy/Binaries/Win64/

My intention was to work in the Debug version, so that when I make mistakes I have the engine to walk through, I find it easier to tell what I did wrong in many cases when I do that. Does Debug Editor not work with HotReload?

I’ve built both my editor and my game project using the Debug Editor profile.

Alright, thank you very much, sort of hope that it doesn’t work for you so that my editor isn’t just incompetent and that there actually is an issue :stuck_out_tongue:

Need to disappoint you works fine with me. I assume you did a full recompile etc.?

Multiple times, on multiple drives, with multiple different engine versions. :confused:

Its a bit late here (3 am) but if you could provide your project somehow than I will take a look when I got some sleep, perhabs someone else might jump in but if you can wait I will try to see how it works at my end, but would like to do that after some good night sleep

Alright thank you, I’ll set something up and send you a message to a link.


Hopefully that should work, if you can’t use the link, just tell me

Remove the SDF file and the Intermediate Folder, itll shrink the whole thing by a large amount of space

Alright, thank you for the advice, I removed both of those files/folders.

Hey Cidubic

Sorry it took so long. I quickly made a test and it worked out for me.

I first regenerated the Project and than did a Build from the Debug Editor. I created a Shortcut to start the Debug in standalone, changed some of the Source Code and than did a Hot Reload.

Huh, okay very lost, I followed the steps you wrote about above, and I got it to work (yay). But then I changed something else and tested the hot-reload again, the second time it failed.

I then closed UE4 and VS, opened UE4 (only ue4 open at this point) tried to hot-reload, still failed, then I close UE4, reopened UE4 rebuilt VS files, tried hot-reload (only ue4), it failed.

Then I closed everything, opened UE4 refreshed VS files, opened VS, tried the hot-load, it worked again, like the first time, then I changed some stuff and it failed on the second try.

Now I closed both, reopened UE4, refreshed the files, opened VS, tried the hot-reload and it failed.

Very unsure of what exactly is going on, each failure results in a Warning like the one above about being Unable to load the module because the file was not found.

Just to make sure when you say re-generate the project you are referring to regenerating the VS project files, no?

Also after that process when I went to go recompile in VS instead of my standard output I got the following: 1>------ Build started: Project: TurnBasedStrategy, Configuration: Debug_Editor - Pastebin.com