4.7 foliage material seems off?

so I changed from 4.6 to 4.7 to try the new foliage material setup yet my materials seems to be really bright looking, its a night scene, my only light in the scene is a directional light with an intensity of 0.01 and an indirect light in post process of 0.002 here are some pictures and my material setup.

All the foliage use a similar kind of material the trees have instanced ones with things like the tint changed a little bit. in the third image the trees on the right are with the foliage tool and the ones on the left are placed individually and they seem to look better is it maybe something to do with that?

When I first built my lighting everything was super bright so I lowered the subsurface tint multiplier so it was darker and it fixed most of it like the grass and stuff but the trees still seem super bright so i dont think that was the root of the problem also the ferns are a little bright too.

Hey Adelphia,

Your material seems a bit complex for what you are trying to do. I wrote a tutorial for Two-Sided Foliage material which is simple and can be added to in case you would like to make it more complex.

Two-Sided Foliage Tutorial

You have a lot of multiplying going on which could be what is causing the material to appear white. You will also want to re-check the ‘Tangent Space Normals’ since you are using a tangent normal.

You can keep your wind effect, but try simplifying your material down first and then going back and incrementally adding more complexity to the shader. This way, if you make a change and get an undesired result, you know exactly what change was made.

If you have any questions or need additional help after attempting the suggestions, please let me know.

Cheers,

Andrew Hurley

hey thanks for that ive actually seen this and took from that and went forward to where i am now the problem im having is this below, I started a new project and followed your steps and it looked good then i turned all the lights out and i get the image below, the one on the left is the foliage shading and the one highlighted is the normal lit model.

it seems that when the lights go off you can still see the subsurface colour but not the base colour because when i turn the lights up i get the second image which has some base colour and subsurface

If you are trying to make a night scene try following the post I answered a while back. The two sided foliage shading model needs some light for it to work correctly. Subsurface color acts differently than base color which is why you are still able to see a bit of it when your lights are off in your scene. Instead of turning your lights off in your scene, try dimming it and changing the post processing effects.

Night Sky Preferences

Let me know when you have attempted the night sky set up I provided in the post above, and if you have any other questions.

Cheers,

Andrew Hurley

one side of my planes are a different colour, slightly darker i think that this is the sub surface colour but its not on the other side as well, any idea whats causing this? i have two sided enabled with the correct shading model for the foliage

You are going to need to brighten your scene because I cannot see much from this screenshot. The slightly darker side is the opposite side of your foliage which is not receiving direct light.

apologies here is a new one, its one side of the plane no matter where its facing.
one side has the sub surface and the other has the base colour it seems becuase when i turn down the lighting i can only see the dark side?

][3]

i changed the sub surface coloiur to purple so you can see its on one side of the plane and not base colour on the other one

Hey Adelphia,

Thank you for the screenshots as it helps me visualize the issue better. This seems like a material issue so would you mind showing me your Material Editor for the ‘purple’ bush including its properties?

Thank you,

Andrew Hurley

no problem here you go.

Great thank you. Do me a favor and connect the alpha of your Base Diffuse texture sample directly to the opacity mask input. Remove the multiply of the subsurface color and use just the diffuse texture sample color. Now set your ‘Opacity’ to a value above 0.5 and your specular to either 0.0 or 0.1.

Let me know your results after making the suggested edits.

Thank you,

Andrew Hurley

done, here is a screenshot
you can still see on side of the plane a darker shade plus its pretty luminous and blown out the red circle is the dark and the yellow the bright and there both facing towards the light

the two images below are what it looks like in the static mesh viewer which works i think, one from below the light and one from above.

Be sure to rebuild your lighting in your scene to see the changes made. Also could you expand the ‘Build Settings’ menu of your mesh and provide a screenshot of that as well?

If you want to see your trees at it’s highest quality you can set your directional light actor to movable.

build setings and the built lighting image still the same problem

i was looking at the world settings and i turned down the Environment Intensity down to 0 and the bright luminous light blue colour has gone and no longer shines when all the lights are turned off and it looks more like the static mesh viewer now. I also put up the indirect lighting to 1

the top one is before i turned the environment colour down and the bottom one is what i have now.
Looking any better?