4.7.2 "object has degenerate tangent bases"

Hello!

Now, I am not really a master of 3dsmax or modeling for that matter. But I made a VERY SIMPLE bridge on 3dsmax, and unwrapped it nicely. Though no matter what I do, I get “object has degenerate tangent bases which will result in incorrect shading” error.

The reason I am posting this as bug report is that, the same mesh is completely perfect with zero problems when I import it to 4.6.1

I am also giving the links to download the mesh. It’s very small. Like 86 Kbps.

or

Thank you for your time!

1 Like

I have the same problem. I have a mesh which is basically all the walls in my scene. I had placeholder door frames in that mesh, so when I modeled the actual door frames I deleted my place-holders, re-exported and then right upon import i get that message OP is talking about. I also got the same error on an other mesh, a simple door (literally a box). I can post the max files here if it helps. Would really appreciate a fix for this as my lighting now looks all messed up.

Hi Achilleon and Danluka,

This is currently being investigated and has been reported with ticket UE-11426.

I’ve added this post to the ticket and will update when there is any relevant information to pass along.

Thank you!

Tim

Cheers! Thanks!

Guys I fixed it. I was going crazy and couldn’t figure it out, so I deleted every face on my mesh one-by-one until I found the culprit. The problem? The face wasn’t correctly UV’d. I must have left “preserve UVs” on in Max while moving something but basically it was just a thin red line in the UV editor. I mapped the face, re-exported. No error. So Achilleon, look for unmapped face in your mesh. Maybe just apply a basic flatten mapping and re-export and see if that fixes it.

While I am happy to see that you have fixed it, I still don’t accept the fact that my mesh is COMPLETELY fine in 4.6.1 but not on 4.7.

It just doesn’t make sense, you see. Anyhow, it’s low importance for me right now so I will do the changes on the mesh when I am highly in need of it.

Anyway, congrats!

Yeah I know it’s weird. But these things happen when an engine is in development. I think I read somewhere that they changed the way tangents are processed in 4.7 - so that might have something to do with it…

something that is a problem for the renderer now might not have been a problem for it before. Have you tried applying a flatten mapping to your object just to see if that fixes it?

To be honest, I don’t even know how to do it.

If you be so kind, can you download the mesh from one of the links and see if it got something wrong? It’s just 86 kbp, a very simple bridge I made in 3dsmax 2015.

Since the bridge will only have one color on it (not even a proper texture) I am not really concerned about it. Though I would like to get some help about it reglardless so I can learn what I have done wrong with it. :slight_smile:

Alright, I hade made a check on my UV problem, and as you said I had some terrible and sneaky “line” wrapped face. Fixed them all and the warning is gone. \ o /

awesome! :smiley:

With regards to Degenerate Tangents, 4.8 will have an option to disable MikkTSpace in the Static Mesh Build settings. This is fixed with CL-2519373.

Hey everyone. I could use some help. I’m running against the same frustrating issue here. I made lightmaps, I deselected “preserve UV’s” in 3ds Max, I tried all sorts of options, and nothing is working. I’m wondering if it even matters and should I just ignore it? I haven’t had this much issues with importing a mesh in UDK. Is there some new process that I’m missing here?

You need to make sure that all the faces on your object are UV mapped.
In my case i had made some changes to my geometry but forgot to map the new faces, which resulted in the error. Try applying a flatten mapping to both uv sets 1 and 2, then re-export.

Also make sure they are -properly- UV mapped. My personal problem was, a face had its UV map as a single line instead of square. When I fixed that the problem was gone.

At the moment 4.7 literally breaks everything of the mapping if it sees a single error. Before that the uv mapping still worked even you had bad uv mapping so you probably didn’t realise. This is fixed at 4.8 but you still need to check where you are making the mistake.

I believe this problem is incorrectly being reported by the engine. This for me is generally a problem with the Lightmap UVs that I apply, or forget to update if I add something to my model. I generally when making UVs for texture maps do some things that are not-standard. I like to use repeatable textures, therefore for my texture UVs i often overlap UVs for front and back facing and sides etc.

However, for Lightmap uvs, the UVs associated with making shadows, I auto generate some light map UVs and don’t tinker unless I see if my shadows look like they are problems. I use Automatic Mapping for Lightmap UVs and I often scale them in from the edges a little bit to allow for shadow bleed. Again, I don’t tinker unless there is a problem.

I don’t seem to get errors for my overlapping UVs for texture-maps, but I get errors for Lightmap UVs, or in this case the Degenerate Tangent Bases. Now whether that error appears for other reasons as well, I can’t yet say.

Guess I missed one post to update when I was commenting on the others.

You’re right. this is completely UV’s that are not setup properly.

This is my go-to post that I’ve responded to when this issue comes up now: Degenerate Tangent Bases - Rendering - Unreal Engine Forums

Also going to move this out of bug reports as this is not a bug.

Feel free to go in 3ds max and in the top left of your viewport where you can configure the view, there is a symbol that represents “[ + ]”

Click it and go down to “xView” and hit Overlapping faces. It will highlight degenerate bases (overlapping faces) in green. This saves time and leads you directly to the issue rather than deleting and remaking every face!

Hope this helps!

I did this and it shows 0 overlapping faces. however when I transfer to UE4.14.3 it still mentioned that there’s degenerate tangent bases. I even peel the UV on my own without using flat mapping and it still show this error. Help I don’t know what I have to do

Still no silid answer on this question but and it slis so so. So on this issue i notice this happens whenever you extrude your geonerty weld or etc…

I figured out the issue im not sure about the older versions but it has to do with the uv’s some people say ignore i sugest you dont…