4.6 Foliage shadows are too dark

I’ve just converted my project from 4.4 to 4.6 and after baking light, the shadows on grass are way too dark. In 4.4 they were fine (maybe because they were dynamic in 4.4?) Maybe it’s because of this new ‘static lighting on foliage’ feature? How i can change opacity of these shadows? PS. I have a skylight in the scene, so that’s not the problem.

Edit: I’ve just noticed that dynamic shadow that is casted by the player is also that dark. Hmm…

UPDATE: Adding an extra directional light (rotated against the first one) makes grass shadows better, but sadly removes all the shadows from static meshes, so i’m afraid that’s not a solution :frowning: So maybe it’s a problem with lighting two-sided materials or masked ones? (because the dark shadow affects only grass and leaves) Image:

Update: On other objects (ground without grass or building) shadows are fine:

22972-fineshadow.png

Update 2: Seems like some leaves of my trees are affected by this dark shadow too:

… And they’re placed manually in editor (not with foliage tool) - so maybe it’s not foliage problem, but something need to be set up in my materials/static meshes?

Hello Slavq,

Just to make sure, you have verified that the meshes casting the dark shadows were not placed in your scene using the foliage tool, but instead or manually placed static meshes?

Thanks,

Andrew H.

I’ve just checked again, and only the grass was placed with foliage tool. Trees and the ruin-thingy were placed manually in editor. I’ve also tried with other different static meshes (houses, big rocks…) and result is the same. As can be seen on the first picture, even the player casts this dark shadow - and he was not placed with foliage tool either :slight_smile:
This dark shadow affects only grass and leaves - so maybe it’s a problem with lighting double-sided or masked materials from one side - because (second picture) adding an extra light helps.

Ok, i have ‘half-answer’ to my question: It’s probably because of my grass / leaf material. The material is simulating wind on grass, the idea is from here: - YouTube

Disconnecting “Normal” input in my material made it better:

It uses normal map to simulate wind-waves effect. When i’ll find out what exactly is causing this shadow darkness (there are plenty of nodes in material), i will post full solution here. But anyway, it’s interesting that in 4.4 shadows were ok - the dark ones showed up after conversion to 4.6.

There are a few things you can try, like checking the world settings of your project. Under the lightmass settings there is an environment color picker which can effect the lightness or darkness of your shadows.

Use this image as a reference to where you can locate this setting. Change it to something light and rebuild your lights to see if this helps.

Environment Color location

I hope this helps you resolve your issue.

Thanks,

Andrew Hurley

I’ve just discovered what was causing this (posted in answer) but Environment Color also helped to brighten it up a little, thanks.

Okay, glad to see you are troubleshooting your own issue really well :slight_smile: I actually just saw that grass shader today and thought it looked fantastic! I am going to put together a small personal project of my own using the material as well using 4.6 so if I get a similar outcome I will let you know.

There have been changes to foliage static lighting in 4.6 and other feature implementations. These changes along with the other features implemented in 4.6 could be having an effect on your current meshes even if they aren’t foliage actors.

Let me know when you get your shadows looking how you would like, if ever, and if you need further assistance.

Thanks again,

Andrew Hurley