4.5 preview shadow issue on mobile

In the mobile previewer,the movable objects can cast shadows on static meshs except on landscape with the directional lights set to movable.Also,the static meshes never cast shadows too.But in the editor everything looks ok. Here’s the screenshot of the mobile previewer.(PS I have one directional light which is movable and with the cast shadows enabled)

Why the landscape doesn’t receive moveable light’s shadows? How to fix this?Thank you!

im not too sure about 4.5,
but as of 4.4.3, mobile does not cast dynamic shadows ( from movable lights), only lighting. shadows have to be baked.
make sure that you have enough resolution on your shadow maps and that you have a lightmass importance volume to accept the movable light LIGHTING. it will still not produce shadows tho. ( unless this was added in 4.5. i read sth about it, but im not sure.)

thanks
the dynamic shadow on mobile is a key feature in 4.5

Howdy hls333555,

I just wanted to check in with you on this issue. Would it be possible to close out this issue due to it being a key feature in 4.5? IF this issue is still occurring when 4.5 is fully released, feel free to re-open this issue so that i may look into the issue again.

Thanks and have a great day!

Howdy hls333555,

Just wanted to let you know that 4.5 has been released today. Please be sure to let me know if the shadow issue is still occurring for you in your project.

Thanks!

Thank you.i have updated the 4.5 .however the mobile preview still cannot cast shadows on landscape while the mobile actual devices can which i think may be a bug.And the lighting of ios(very dark and seems that the skylight for the indirect lighting does not work) is quite different from that on android( which is similar to the mobile preview except shadows).

on the other hand i can never make the water look realistic(like pc) with a movable directionl light,it has no reflections even if i place the reflection capture and it looks as if it were a plane and does not have waves…

And here are two screenshots, the upper below is the poor effect on ipad air (with metal enabled),the other is on my Qualcomm 800 Android devices.

Hey hls333555,

You said that there is a skylight in your scene correct? If so, is that Skylight movable or static?

It is directionary and i have tried movable,that does nothing…
Here’s my skylight property:

Any info available?

Hey hls333555,

I have reached out to a fellow developer on the issue. They are looking into the issue and I will respond back as soon as I hear any information on the issue.

Thanks!

Do you have mobile hdr disabled? I’m looking into why it doesn’t work when it’s off.

We have a known bug in the mobile hdr off rendering path where some features are not working, such as (this) skylight and scene captures. We will try to get this fixed for 4.6, The current workaround is to enable mobile hdr in your project. Sorry for the inconvenience!

I use the default settings for mobile with mobile hdr enabled. And it works well on anxroid except ios.

And as seen in the screenshot above the umg cannot be rendered correctly on ios while the android can.

I’ll send the umg bug to our ios expert; i’m looking into the skylight bug; I did manage to repro & fix the non-hdr case, but can’t get your other case yet. Still investigating.

Hey hls333555,

I was testing out your issue and have not been able to reproduce the issue since the 4.5 update of UE4. It may be the settings of your Skylight that is causing the issue. If you delete that skylight and then place a new skylight into your level, are you still able to see the error when you deploy to a device?

Thanks!

Hi, I have been following this thread as I was having identical issues with the dynamic shadows. I simply could not get the skylight to have any effect on the ipad air I am testing on.

I tried a variety of things but in the end I unchecked the “Metal” checkbox in the IOS project settings and checked for “Open GLES”.

That’s fixed it and it matches the mobile previewer display.

This scene contains,

  • One directional, movable light.
  • One stationary skylight (Which is odd because the documentation says that only static skylights work on mobile. However, using a static skylight doesn’t work and you get black shadows)
  • A sky dome with a simple emissive material.
  • Metal API disabled

Hope that works for you.

Thanks for the information and setup TeamKingdom!

@hls333555, Please be sure to let me know if this information was helpful for you and your project.

Thanks!

Thank you all!However,after i update to 4.5.1, i check the opengles and uncheck the metal,the editor crashes when i hit package project-----ios…

Also,the 4.5.1 still cannot cast shadow on landscape in mobile preview while it can on mobile devices…

PS:When will the the metal support skylight?Thank you!