4.22 Raytracing with GTX 1080?

hi there, few days ago got the Nividia driver update saying could run Ray tracing with GTX 1080 card, is that working?

I been doing test and nothing happens.


Yes, make sure your Windows 10 is updated to October 2018 update which officially added DXR, otherwise RayTracing wont work at all in your system regardless of driver. You can test ray tracing with NVidia tech demo Justice which is not that demanding (it runs pretty well on my 1080Ti, sometimes pretty smooth), if everything goes fine you should have RT option not gray out in beginning, if its gray out then it means you missing something:

Now on UE4, you will need to run editor with DX12 RHI (UE4 by default runs DX11 RHI), you do this by runnning editor with -dx12 option in command line. Then in project you need to enable Raytracing (just search it with search bar in Project Settings) and restart editor. And thats it, you should immediately see effects of ray tracing in all reflective materials.

Ray Tracing have lot small options allowing to enable/disable individual ray tracing rendering features, in console type in r.Raytracing and console should suggest you all of them.

Thanks! it works!

I been trying it today with No luck
updated windows 10 & Nvidia update driver
turned on the Ray tracing option in project settings
Nothing is happening

how did you get it to work with the GTX 1080

you have to update your windows from the website, not automatic update, is take ages! , but after that it works :slight_smile:

Thanks Baolong
This works!

Hi. I am using the Nvidia Geforce Gtx Titan X video card. Windows version 1809. Nvidia installed update 425.31. I’m working with the Ue4 4.22 version -dx12. But I didn’t see any change in ray tracing. I don’t know what I have to do, but I hope you can help.

Did you change the Project setting ? switch on Ray tracing?

Yes i opened.

I have the exact same issue and I’m also using a TitanX. Surely this card is supported right?

I’m on 1809 and will try to update windows some more.
If i find the solution I will let you know. Please do the same.